ltp: Fix building on ARM.
authorTom Rini <trini@embeddedalley.com>
Thu, 2 Apr 2009 00:16:23 +0000 (20:16 -0400)
committerTom Rini <trini@embeddedalley.com>
Thu, 2 Apr 2009 00:16:23 +0000 (20:16 -0400)
The no_epoll_create2_mips.patch also applies for ARM, and probably
a few others still (that I haven't tried).  Rename to no_epoll_create2.patch
and apply on arm/armeb.

recipes/ltp/ltp-20090131/no_epoll_create2.patch [new file with mode: 0644]
recipes/ltp/ltp-20090131/no_epoll_create2_mips.patch [deleted file]
recipes/ltp/ltp_20090131.bb

diff --git a/recipes/ltp/ltp-20090131/no_epoll_create2.patch b/recipes/ltp/ltp-20090131/no_epoll_create2.patch
new file mode 100644 (file)
index 0000000..84ce8e4
--- /dev/null
@@ -0,0 +1,17 @@
+---
+ testcases/kernel/syscalls/Makefile |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: ltp-full-20090131/testcases/kernel/syscalls/Makefile
+===================================================================
+--- ltp-full-20090131.orig/testcases/kernel/syscalls/Makefile
++++ ltp-full-20090131/testcases/kernel/syscalls/Makefile
+@@ -25,7 +25,7 @@ EXCLUDE_DIR=epoll
+ #
+ # Commented this out since there are directories here we don't want built by default
+ #
+-SUBDIR = `ls */Makefile | sed "s/Makefile//g"` 
++SUBDIR = `ls */Makefile | sed "s/Makefile//g | grep -vE "^epoll_create2""` 
+ UCLINUX_SUBDIR = `ls */Makefile | sed "s/Makefile//g" | grep -vE "^fork|epoll|capget|capset|chmod|chown|llseek|nftw|clone|profil|getcontext"`
+ all:
diff --git a/recipes/ltp/ltp-20090131/no_epoll_create2_mips.patch b/recipes/ltp/ltp-20090131/no_epoll_create2_mips.patch
deleted file mode 100644 (file)
index 84ce8e4..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
----
- testcases/kernel/syscalls/Makefile |    2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-Index: ltp-full-20090131/testcases/kernel/syscalls/Makefile
-===================================================================
---- ltp-full-20090131.orig/testcases/kernel/syscalls/Makefile
-+++ ltp-full-20090131/testcases/kernel/syscalls/Makefile
-@@ -25,7 +25,7 @@ EXCLUDE_DIR=epoll
- #
- # Commented this out since there are directories here we don't want built by default
- #
--SUBDIR = `ls */Makefile | sed "s/Makefile//g"` 
-+SUBDIR = `ls */Makefile | sed "s/Makefile//g | grep -vE "^epoll_create2""` 
- UCLINUX_SUBDIR = `ls */Makefile | sed "s/Makefile//g" | grep -vE "^fork|epoll|capget|capset|chmod|chown|llseek|nftw|clone|profil|getcontext"`
- all:
index 61775cf..4793d24 100644 (file)
@@ -14,8 +14,10 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/ltp/ltp-full-${PV}.tgz \
            file://no-IDcheck.patch;patch=1 \
            file://no_hyperthreading_tests.patch;patch=1"
 
-SRC_URI_append_mips += "file://no_epoll_create2_mips.patch;patch=1"
-SRC_URI_append_mipsel += "file://no_epoll_create2_mips.patch;patch=1"
+SRC_URI_append_mips += "file://no_epoll_create2.patch;patch=1"
+SRC_URI_append_mipsel += "file://no_epoll_create2.patch;patch=1"
+SRC_URI_append_arm += "file://no_epoll_create2.patch;patch=1"
+SRC_URI_append_armeb += "file://no_epoll_create2.patch;patch=1"
 
 S = "${WORKDIR}/ltp-full-${PV}"