bzip2: add patch to use LDFLAGS (fixes QA error)
authorJeremy Lainé <jeremy.laine@m4x.org>
Thu, 2 Apr 2009 12:47:37 +0000 (12:47 +0000)
committerJeremy Lainé <jeremy.laine@m4x.org>
Thu, 2 Apr 2009 12:47:37 +0000 (12:47 +0000)
recipes/bzip2/bzip2-1.0.2/ldflags.patch [new file with mode: 0644]
recipes/bzip2/bzip2_1.0.2.bb

diff --git a/recipes/bzip2/bzip2-1.0.2/ldflags.patch b/recipes/bzip2/bzip2-1.0.2/ldflags.patch
new file mode 100644 (file)
index 0000000..c7da5bc
--- /dev/null
@@ -0,0 +1,14 @@
+diff -urN bzip2-1.0.2.orig/Makefile-libbz2_so bzip2-1.0.2/Makefile-libbz2_so
+--- bzip2-1.0.2.orig/Makefile-libbz2_so        2001-12-30 02:15:59.000000000 +0000
++++ bzip2-1.0.2/Makefile-libbz2_so     2009-04-02 12:42:43.000000000 +0000
+@@ -20,8 +20,8 @@
+       bzlib.o
+ all: $(OBJS)
+-      $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.2 $(OBJS)
+-      $(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.2
++      $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.2 $(OBJS)
++      $(CC) $(CFLAGS) $(LDFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.2
+       rm -f libbz2.so.1.0
+       ln -s libbz2.so.1.0.2 libbz2.so.1.0
index 1e1cb8e..9e8cb20 100644 (file)
@@ -1,10 +1,11 @@
 DESCRIPTION = "Very high-quality data compression program."
 SECTION = "console/utils"
-PR = "r1"
+PR = "r2"
 
 LICENSE = "bzip2"
 SRC_URI = "ftp://sources.redhat.com/pub/bzip2/v102/bzip2-${PV}.tar.gz \
-          file://installpaths.patch;patch=1"
+          file://installpaths.patch;patch=1 \
+          file://ldflags.patch;patch=1"
 
 CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"