gst-openmax: add openmax IL support for gstreamer
authorKoen Kooi <koen@openembedded.org>
Tue, 5 Aug 2008 15:57:15 +0000 (15:57 +0000)
committerKoen Kooi <koen@openembedded.org>
Tue, 5 Aug 2008 15:57:15 +0000 (15:57 +0000)
packages/openmax/gst-openmax/.mtn2git_empty [new file with mode: 0644]
packages/openmax/gst-openmax/check.diff [new file with mode: 0644]
packages/openmax/gst-openmax_0.10.0.4.bb [new file with mode: 0644]

diff --git a/packages/openmax/gst-openmax/.mtn2git_empty b/packages/openmax/gst-openmax/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/openmax/gst-openmax/check.diff b/packages/openmax/gst-openmax/check.diff
new file mode 100644 (file)
index 0000000..9e74abf
--- /dev/null
@@ -0,0 +1,11 @@
+--- /tmp/gst-check.m4  2008-08-05 17:46:09.000000000 +0200
++++ gst-openmax-0.10.0.4/common/m4/gst-check.m4        2008-08-05 17:46:29.000000000 +0200
+@@ -114,7 +114,7 @@
+ AC_DEFUN([AG_GST_CHECK_GST_CHECK],
+ [
+-  AG_GST_CHECK_MODULES(GST_CHECK, gstreamer-check-[$1], [$2],
++  AG_GST_CHECK_MODULES(GST_CHECK, gstreamer-check, [$2],
+     [GStreamer Check unittest Library], [$3])
+ ])
diff --git a/packages/openmax/gst-openmax_0.10.0.4.bb b/packages/openmax/gst-openmax_0.10.0.4.bb
new file mode 100644 (file)
index 0000000..39f3538
--- /dev/null
@@ -0,0 +1,18 @@
+DESCRIPTION = "GstOpenMAX is a GStreamer plug-in that allows communication with OpenMAX IL components"
+LICENSE = "LGPLv2"
+DEPENDS = "gstreamer libomxil-bellagio"
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/gst-openmax/pre/gst-openmax-${PV}.tar.bz2 \
+           file://check.diff;patch=1 \
+          "
+
+inherit autotools
+
+do_stage() {
+       autotools_stage_all
+}
+
+FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
+FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
+FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.*a"
+