ogre-egl: build samples against a modern toolkit and package them
authorKoen Kooi <koen@openembedded.org>
Wed, 11 Feb 2009 08:38:33 +0000 (09:38 +0100)
committerKoen Kooi <koen@openembedded.org>
Wed, 11 Feb 2009 08:38:33 +0000 (09:38 +0100)
packages/ogre/ogre-egl_svn.bb

index 61d2429..9ca9e8f 100644 (file)
@@ -1,8 +1,8 @@
 DESCRIPTION = "OGRE (Object-Oriented Graphics Rendering Engine) is a scene-oriented, flexible 3D engine "
 LICENSE = "LGPL"
-DEPENDS = "zziplib boost freeimage freetype virtual/libx11 virtual/egl"
+DEPENDS = "gtk+ wgois cppunit zziplib boost freeimage freetype virtual/libx11 virtual/egl"
 
-PR = "r1"
+PR = "r3"
 
 SRCREV = "8310"
 PV = "1.6.1+svnr${SRCREV}"
@@ -14,7 +14,7 @@ SRC_URI = "svn://ogre.svn.sourceforge.net/svnroot/ogre;module=trunk;proto=https
 inherit autotools_stage
 
 # This is the EGL version
-EXTRA_OECONF = " --with-allocator=std --enable-threading=no --disable-cg --enable-gles "
+EXTRA_OECONF = " --with-gui=gtk --disable-freetypetest --enable-ogre-demos --with-allocator=std --enable-threading=no --disable-cg --enable-gles "
 
 S = "${WORKDIR}/trunk"
 
@@ -25,7 +25,20 @@ do_configure_prepend() {
        sed -i -e /OGRE_DETECT_ENDIAN/d ${S}/configure.in
 }
 
-FILES_${PN}-dbg += "${libdir}/OGRE/.debug"
+do_install_append() {
+       install -d ${D}${datadir}/ogre3d/samples
+       mv ${D}${S}/Samples/* ${D}${datadir}/ogre3d/samples/
+       cp ${S}/Samples/Common/bin/Release/*cfg ${D}${datadir}/ogre3d/samples/Common/bin
+
+       install -d ${D}${datadir}/ogre3d/Media 
+       cp -r ${S}/Samples/Media/* ${D}${datadir}/ogre3d/Media/
+       find ${D} -name ".svn" | xargs rm -rf
+}
+
+PACKAGES += "${PN}-samples"
+
+FILES_${PN}-samples = "${datadir}/ogre3d/"
+FILES_${PN}-dbg += "${libdir}/OGRE/.debug ${datadir}/ogre3d/samples/*/*/.debug"
 FILES_${PN}-dev += "${libdir}/OGRE/*.la"
 FILES_${PN} += "${libdir}/libOgreMain-*.so ${libdir}/OGRE/*.so"