sqlite: use LDFLAGS (fixes QA error)
authorJeremy Lainé <jeremy.laine@m4x.org>
Thu, 2 Apr 2009 20:17:29 +0000 (20:17 +0000)
committerJeremy Lainé <jeremy.laine@m4x.org>
Thu, 2 Apr 2009 20:17:29 +0000 (20:17 +0000)
recipes/sqlite/sqlite-2.8.17/mainmk_build_dynamic.patch
recipes/sqlite/sqlite_2.8.17.bb

index e936f81..914422f 100644 (file)
@@ -1,6 +1,6 @@
-diff -bur sqlite-2.8.17~orig/main.mk sqlite-2.8.17/main.mk
---- sqlite-2.8.17~orig/main.mk 2005-04-23 17:43:23.000000000 -0500
-+++ sqlite-2.8.17/main.mk      2006-02-13 03:31:03.000000000 -0600
+diff -urN sqlite-2.8.17.orig/main.mk sqlite-2.8.17/main.mk
+--- sqlite-2.8.17.orig/main.mk 2005-04-23 22:43:23.000000000 +0000
++++ sqlite-2.8.17/main.mk      2009-04-02 20:10:36.000000000 +0000
 @@ -139,7 +139,7 @@
  # This is the default Makefile target.  The objects listed here
  # are what get build when you type just "make" with no arguments.
@@ -17,13 +17,15 @@ diff -bur sqlite-2.8.17~orig/main.mk sqlite-2.8.17/main.mk
 -libsqlite.a:  $(LIBOBJ)
 -      $(AR) libsqlite.a $(LIBOBJ)
 -      $(RANLIB) libsqlite.a
-+libsqlite.so: $(LIBOBJ)
-+      $(CC) -shared -o libsqlite.so -Wl,-soname,libsqlite.so.0 $(LIBOBJ)
+-
 -sqlite$(EXE): $(TOP)/src/shell.c libsqlite.a sqlite.h
-+sqlite$(EXE): $(TOP)/src/shell.c libsqlite.so sqlite.h
-       $(TCCX) $(READLINE_FLAGS) -o sqlite$(EXE) $(TOP)/src/shell.c \
+-      $(TCCX) $(READLINE_FLAGS) -o sqlite$(EXE) $(TOP)/src/shell.c \
 -              libsqlite.a $(LIBREADLINE) $(THREADLIB)
++libsqlite.so: $(LIBOBJ)
++      $(CC) $(LDFLAGS) -shared -o libsqlite.so -Wl,-soname,libsqlite.so.0 $(LIBOBJ)
++
++sqlite$(EXE): $(TOP)/src/shell.c libsqlite.so sqlite.h
++      $(TCCX) $(LDFLAGS) $(READLINE_FLAGS) -o sqlite$(EXE) $(TOP)/src/shell.c \
 +              -lsqlite $(LIBREADLINE) $(THREADLIB)
  
  sqlite_analyzer$(EXE):        $(TOP)/src/tclsqlite.c libsqlite.a $(TESTSRC) \
index b5939d9..9f6ec7e 100644 (file)
@@ -4,7 +4,7 @@ SECTION = "libs"
 PRIORITY = "optional"
 DEPENDS = "readline ncurses"
 LICENSE = "PD"
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "http://www.hwaci.com/sw/sqlite/sqlite-${PV}.tar.gz \
        file://mainmk_build_dynamic.patch;patch=1 \