merge of '19595382c19aadeee7dac4939deb285a05e428eb'
authorMichael Lauer <mickey@vanille-media.de>
Sun, 3 Feb 2008 23:36:10 +0000 (23:36 +0000)
committerMichael Lauer <mickey@vanille-media.de>
Sun, 3 Feb 2008 23:36:10 +0000 (23:36 +0000)
     and '31ced983465ce39a8b2be69de54096ba17a8b404'

14 files changed:
conf/distro/include/sane-srcrevs.inc
conf/machine/h5000.conf
packages/gsm/files/default
packages/gsm/gsmd.inc
packages/inetutils/inetutils_1.5.bb [new file with mode: 0644]
packages/linux/linux-openmoko_2.6.24.bb
packages/opie-ttf-support/opie-ttf-support_1.1.bb
packages/qemu/qemu-0.9.1/writev_fix.patch [new file with mode: 0644]
packages/qemu/qemu_0.9.1.bb
packages/tasks/task-base.bb
packages/xorg-app/bdftopcf-native_1.0.0.bb
packages/xorg-font/font-util-native_1.0.1.bb
packages/xorg-xserver/xserver-kdrive-1.4/keyboard-resume-workaround.patch [new file with mode: 0644]
packages/xorg-xserver/xserver-kdrive_1.4.bb

index 50ba415..3411f2b 100644 (file)
@@ -45,7 +45,7 @@ SRCREV_pn-libxosd ?= "627"
 SRCREV_pn-linux-bfin ?= "3758"
 SRCREV_pn-linux-hackndev-2.6 ?= "1308"
 SRCREV_pn-linux-ixp4xx ?= "1021"
-SRCREV_pn-linux-openmoko ?= "3801"
+SRCREV_pn-linux-openmoko ?= "4013"
 SRCREV_pn-llvm-gcc4 ?= "374"
 SRCREV_pn-llvm-gcc4-cross ?= "374"
 SRCREV_pn-maemo-mapper ?= "118"
index c4c1237..1f29438 100644 (file)
@@ -27,7 +27,8 @@ EXTRA_IMAGECMD_jffs2 = "-e 0x40000 -p ; echo '${IMAGE_NAME}  ${IMAGE_NAME}.rootf
 MACHINE_EXTRA_RDEPENDS = "kernel ipaq-boot-params"
 MACHINE_EXTRA_RRECOMMENDS = " kernel-module-h5400-lcd \
                              kernel-module-h5400-battery \
-                             kernel-module-snd-soc-h5000"
+                             kernel-module-snd-soc-h5000 \
+                             kernel-module-i2c-pxa"
 
 #
 # Modules autoload and other boot properties
index f113d8b..467bd33 100644 (file)
@@ -5,8 +5,13 @@
 case `machine_id` in
        "gta01"|"gta02")
                GSMD_OPTS="-s 115200 -F"
+               if [ -d '/sys/bus/platform/devices/gta01-pm-gsm.0' ] ; then
                GSM_POW="/sys/bus/platform/devices/gta01-pm-gsm.0/power_on"
                GSM_RES="/sys/bus/platform/devices/gta01-pm-gsm.0/reset"
+               else
+               GSM_POW="/sys/bus/platform/devices/neo1973-pm-gsm.0/power_on"
+               GSM_RES="/sys/bus/platform/devices/neo1973-pm-gsm.0/reset"
+               fi
                GSM_DEV="/dev/ttySAC0"
                ;;
        "htc_apache"|"htc_blueangel"|"htc_universal")
index f7d609e..a6b6fb7 100644 (file)
@@ -5,7 +5,7 @@ SECTION = "libs/gsm"
 PROVIDES += "gsmd"
 RPROVIDES_${PN} = "libgsmd0 libgsmd gsmd gsmd-devel"
 PV = "0.1+svnr${SRCREV}"
-PR = "r40"
+PR = "r41"
 
 SRC_URI = "svn://svn.openmoko.org/trunk/src/target;module=gsm;proto=http \
            file://gsmd \
diff --git a/packages/inetutils/inetutils_1.5.bb b/packages/inetutils/inetutils_1.5.bb
new file mode 100644 (file)
index 0000000..0971e58
--- /dev/null
@@ -0,0 +1,17 @@
+SECTION = "libs"
+DEPENDS = "ncurses"
+LICENSE = "GPL"
+DESCRIPTION = "The GNU inetutils are a collection of common \
+networking utilities and servers including ftp, ftpd, rcp, \
+rexec, rlogin, rlogind, rsh, rshd, syslog, syslogd, talk, \
+talkd, telnet, telnetd, tftp, tftpd, and uucpd."
+
+SRC_URI = "${GNU_MIRROR}/inetutils/inetutils-${PV}.tar.gz"
+
+inherit autotools
+
+EXTRA_OECONF = "--with-ncurses-include-dir=${STAGING_INCDIR}"
+
+do_configure_prepend () {
+       rm -f ${S}/glob/configure*
+}
index d58f231..0c63fc9 100644 (file)
@@ -5,10 +5,10 @@ DESCRIPTION = "Linux 2.6.x (development) kernel for FIC SmartPhones shipping w/
 VANILLA_VERSION = "2.6.24"
 KERNEL_RELEASE = "2.6.24"
 
-KERNEL_VERSION = "${KERNEL_RELEASE}"
+KERNEL_VERSION = "${KERNEL_RELEASE}-moko11"
 
 PV = "${VANILLA_VERSION}+svnr${SRCREV}"
-PR = "r1"
+PR = "r2"
 
 KERNEL_IMAGETYPE = "uImage"
 UBOOT_ENTRYPOINT = "30008000"
@@ -54,7 +54,7 @@ do_prepatch() {
         mv ${WORKDIR}/patches ${S}/patches && cd ${S} && quilt push -av
         mv patches patches.openmoko
         mv .pc .pc.old
-        mv ${WORKDIR}/config/defconfig-${KERNEL_VERSION} ${WORKDIR}/defconfig
+        mv ${WORKDIR}/config/defconfig-${KERNEL_RELEASE} ${WORKDIR}/defconfig
 }
 
 addtask prepatch after do_unpack before do_patch
index d11d8ea..c6ed53f 100644 (file)
@@ -1,23 +1,33 @@
 DESCRIPTION = "Meta-package for Opie TTF support"
 SECTION = "opie/fonts"
 DEPENDS = "freetype"
-PR = "r3"
+PR = "r4"
 
 SRC_URI = "file://update-qtttffontdir.c"
 S = "${WORKDIR}"
 
 do_compile() {
-       ${CC} ${CFLAGS} ${LDFLAGS} -I${STAGING_INCDIR}/freetype2 -lfreetype -o update-qtttffontdir update-qtttffontdir.c
+        ${CC} ${CFLAGS} ${LDFLAGS} -I${STAGING_INCDIR}/freetype2 -lfreetype -o update-qtttffontdir update-qtttffontdir.c
 }
 
 do_install() {
-       install -d ${D}${sbindir}
-       install -d ${D}${sysconfdir}/update-fonts-common.d/
-       install -m 0755 update-qtttffontdir ${D}${sbindir}
+
         echo "
 #!/bin/sh
 # Author: Rolf Leggewie
 
 ${sbindir}/update-qtttffontdir ${datadir}/fonts/truetype > ${palmtopdir}/lib/fonts/fontdir
-" > ${D}${sysconfdir}/update-fonts-common.d/02qtttffont-update
+" > ${WORKDIR}/02qtttffont-update
+
+        install -d ${D}${sbindir}
+        install -d ${D}${sysconfdir}/update-fonts-common.d/
+        install -m 0755 update-qtttffontdir ${D}${sbindir}
+        install -m 0755 02qtttffont-update ${D}${sysconfdir}/update-fonts-common.d/
+}
+
+pkg_postinst() {
+        if ! [ -d ${palmtopdir}/lib/fonts ]; then
+            mkdir -p ${palmtopdir}/lib/fonts
+        fi
+        ${sysconfdir}/update-fonts-common.d/02qtttffont-update
 }
diff --git a/packages/qemu/qemu-0.9.1/writev_fix.patch b/packages/qemu/qemu-0.9.1/writev_fix.patch
new file mode 100644 (file)
index 0000000..e0ed4af
--- /dev/null
@@ -0,0 +1,17 @@
+---
+ linux-user/syscall.c |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: qemu-0.9.1/linux-user/syscall.c
+===================================================================
+--- qemu-0.9.1.orig/linux-user/syscall.c       2008-02-03 00:00:00.000000000 +0000
++++ qemu-0.9.1/linux-user/syscall.c    2008-02-03 00:00:38.000000000 +0000
+@@ -1048,7 +1048,7 @@ static abi_long lock_iovec(int type, str
+         base = tswapl(target_vec[i].iov_base);
+         vec[i].iov_len = tswapl(target_vec[i].iov_len);
+         vec[i].iov_base = lock_user(type, base, vec[i].iov_len, copy);
+-      if (!vec[i].iov_base) 
++      if (!vec[i].iov_base && vec[i].iov_len) 
+             goto fail;
+     }
+     unlock_user (target_vec, target_addr, 0);
index 2f0aba7..164296b 100644 (file)
@@ -1,6 +1,6 @@
 LICENSE = "GPL"
 DEPENDS = "zlib"
-PR = "r6"
+PR = "r7"
 
 FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
 FILESDIR = "${WORKDIR}"
@@ -31,6 +31,7 @@ SRC_URI = "\
     file://qemu-amd64-32b-mapping-0.9.0.patch;patch=1 \
     file://workaround_bad_futex_headers.patch;patch=1 \
     file://fix_segfault.patch;patch=1 \
+    file://writev_fix.patch;patch=1 \
     file://configure_symlinkpath_fix.patch;patch=1 \
     file://disable-error-in-configure.patch;patch=1 \
     file://no-strip.patch;patch=1"
index a44056f..f8a94c6 100644 (file)
@@ -1,5 +1,5 @@
 DESCRIPTION = "Merge machine and distro options to create a basic machine task/package"
-PR = "r58"
+PR = "r59"
 
 inherit task
 
index 8ab592b..4104994 100644 (file)
@@ -1,13 +1,8 @@
-DESCRIPTION = "Native bdftopdf utility"
-SECTION = "x11/fonts"
-LICENSE = "MIT-X"
+inherit native
+require xorg-app-common.inc
 PE = "1"
 
-S="${WORKDIR}/bdftopcf-${PV}"
+XORG_PN = "bdftopcf"
 
 DEPENDS = "libxfont-native"
 
-SRC_URI = "${XORG_MIRROR}/X11R7.0/src/app/bdftopcf-X11R7.0-1.0.0.tar.gz"
-
-inherit native autotools pkgconfig
-
index 8db0b71..32ea62c 100644 (file)
@@ -1,13 +1,8 @@
-DESCRIPTION = "X font utils."
-SECTION = "x11/fonts"
-LICENSE = "MIT-X"
+inherit native
+require xorg-font-common.inc
 
-S="${WORKDIR}/font-util-${PV}"
+XORG_PN = "font-util"
 
 DEPENDS = "bdftopcf-native"
 
 PE = "1"
-
-SRC_URI = "${XORG_MIRROR}/X11R7.1/src/font/font-util-${PV}.tar.gz"
-
-inherit native autotools pkgconfig
diff --git a/packages/xorg-xserver/xserver-kdrive-1.4/keyboard-resume-workaround.patch b/packages/xorg-xserver/xserver-kdrive-1.4/keyboard-resume-workaround.patch
new file mode 100644 (file)
index 0000000..4964ff5
--- /dev/null
@@ -0,0 +1,16 @@
+Index: xorg-server-1.4/hw/kdrive/linux/keyboard.c
+===================================================================
+--- xorg-server-1.4.orig/hw/kdrive/linux/keyboard.c    2007-09-29 18:31:15.000000000 +0200
++++ xorg-server-1.4/hw/kdrive/linux/keyboard.c 2007-09-29 18:33:02.000000000 +0200
+@@ -743,11 +743,6 @@
+     cfsetispeed(&nTty, 9600);
+     cfsetospeed(&nTty, 9600);
+     tcsetattr(fd, TCSANOW, &nTty);
+-    /*
+-     * Flush any pending keystrokes
+-     */
+-    while ((n = read (fd, buf, sizeof (buf))) > 0)
+-      ;
+     KdRegisterFd (fd, LinuxKeyboardRead, ki);
+     return Success;
+ }
index f4d5be3..c870901 100644 (file)
@@ -3,7 +3,7 @@ require xserver-kdrive-common.inc
 DEPENDS += "hal libxkbfile libxcalibrate pixman"
 
 PE = "1"
-PR = "r2"
+PR = "r3"
 
 SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
        ${KDRIVE_COMMON_PATCHES} \
@@ -20,6 +20,7 @@ SRC_URI = "${XORG_MIRROR}/individual/xserver/xorg-server-${PV}.tar.bz2 \
        file://xcalibrate-new-input-world-order.patch;patch=1 \
        file://tslib-default-device.patch;patch=1 \
        file://fbdev-evdev.patch;patch=1 \
+       file://keyboard-resume-workaround.patch;patch=1 \
        file://xorg-avr32-support.diff;patch=1 \
         "