qscintilla 1.65: add patch to remove bogus DynLibrary use when built against Qt/Embedded
authorMichael Lauer <mickey@vanille-media.de>
Thu, 4 May 2006 13:56:00 +0000 (13:56 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Thu, 4 May 2006 13:56:00 +0000 (13:56 +0000)
packages/qscintilla/files/.mtn2git_empty [new file with mode: 0644]
packages/qscintilla/files/no-external-lexers.patch [new file with mode: 0644]
packages/qscintilla/qscintilla_1.65-gpl-1.6.bb

diff --git a/packages/qscintilla/files/.mtn2git_empty b/packages/qscintilla/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/qscintilla/files/no-external-lexers.patch b/packages/qscintilla/files/no-external-lexers.patch
new file mode 100644 (file)
index 0000000..5953043
--- /dev/null
@@ -0,0 +1,24 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- ../src/ExternalLexer.cpp~no-external-lexers
++++ ../src/ExternalLexer.cpp
+@@ -110,7 +110,7 @@
+       // Initialise some members...
+       first = NULL;
+       last = NULL;
+-
++#ifndef ZPATCH
+       // Load the DLL
+       lib = DynamicLibrary::Load(ModuleName);
+       if (lib->IsValid()) {
+@@ -155,6 +155,7 @@
+                       }
+               }
+       }
++#endif
+       next = NULL;
+ }
index a313d8c..1620ef6 100644 (file)
@@ -4,7 +4,8 @@ MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
 LICENSE = "GPL"
 PR = "r0"
 
-SRC_URI = "http://www.mneuroth.de/privat/zaurus/qscintilla-${PV}_zaurus.tar.gz"
+SRC_URI = "http://www.mneuroth.de/privat/zaurus/qscintilla-${PV}_zaurus.tar.gz \
+           file://no-external-lexers.patch;patch=1;pnum=0"
 
 S = "${WORKDIR}/qscintilla-${PV}/qt"
 
@@ -12,7 +13,8 @@ inherit opie
 
 QMAKE_PROFILES = "qscintilla.pro"
 
-EXTRA_QMAKEVARS_POST += " CONFIG-=thread INCLUDEPATH+=${S}/patches DEFINES+=ZPATCH \
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${S}/patches \
+                         DEFINES+=ZPATCH DEFINES+=ZAURUS \
                         HEADERS-=qextscintillaprinter.h \
                         SOURCES-=qextscintillaprinter.cpp \
                         SOURCES+=patches/qsettings.cpp \
@@ -21,8 +23,14 @@ EXTRA_QMAKEVARS_POST += " CONFIG-=thread INCLUDEPATH+=${S}/patches DEFINES+=ZPAT
 
 PARALLEL_MAKE = ""
 
-
 do_stage() {
        install -m 0644 qextscintilla*.h ${STAGING_INCDIR}/
        oe_libinstall -so libqscintilla ${STAGING_LIBDIR}
 }
+
+do_install() {
+       install -d ${D}${libdir}
+       oe_libinstall -so libqscintilla ${D}${libdir}
+}
+
+FILES_${PN} = "${libdir}"