klibc.inc: reformat SRC_URI, add fstype-sane-vfat-and-jffs2 patch
authorThomas Kunze <thommycheck@gmx.de>
Thu, 28 Feb 2008 12:52:39 +0000 (12:52 +0000)
committerThomas Kunze <thommycheck@gmx.de>
Thu, 28 Feb 2008 12:52:39 +0000 (12:52 +0000)
Change of SRC_URI was necessary because the eabi patch wasn't always appllied
by bitbake.

packages/klibc/klibc-common.inc
packages/klibc/klibc-utils-static_1.5.bb
packages/klibc/klibc_1.5.bb

index 76e3937..7b23ece 100644 (file)
@@ -4,7 +4,9 @@ DESCRIPTION = "klibc is intended to be a minimalistic libc subset for \
 use with initramfs.  It is deliberately written for small size, \
 minimal entaglement, and portability, not speed."
 LICENSE = "BSD-ADV"
-SRC_URI = "${KERNELORG_MIRROR}/pub/linux/libs/klibc/Stable/klibc-${PV}.tar.bz2"
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/libs/klibc/Stable/klibc-${PV}.tar.bz2 \
+          file://fstype-sane-vfat-and-jffs2-for-1.5.patch;patch=1 \
+          "
 S = "${WORKDIR}/klibc-${PV}"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
@@ -16,8 +18,10 @@ KLIBC_ARCH_mipsel = 'mips'
 # could be fixed, but for the moment:
 ARM_INSTRUCTION_SET = "arm"
 
-SRC_URI_append_linux-gnueabi = "file://klibc-config-eabi.patch;patch=1"
-SRC_URI_append_linux-uclibcgnueabi = "file://klibc-config-eabi.patch;patch=1"
+SRC_URI_append_linux-gnueabi = "file://klibc-config-eabi.patch;patch=1 \
+                               "
+SRC_URI_append_linux-uclibcgnueabi = "file://klibc-config-eabi.patch;patch=1 \
+                                     "
 
 EXTRA_OEMAKE = "'KLIBCARCH=${KLIBC_ARCH}' \
                 'CROSS_COMPILE=${TARGET_PREFIX}' \
index f9c9923..6d7a199 100644 (file)
@@ -1,7 +1,6 @@
 require klibc-common.inc
 
-PR = "r6"
-
+PR = "r7"
 
 # We only want the static utils. klibc build both. So we install only what we want.                            
 do_install() {
index 71eed9f..b5bd355 100644 (file)
@@ -1,2 +1,2 @@
 require klibc.inc
-PR = "r4"
+PR = "r5"