udev: get rid of 'timestamp in the future' tar messages
authorPetr Štetiar <ynezz@true.cz>
Wed, 27 Jan 2010 07:58:36 +0000 (07:58 +0000)
committerPhilip Balister <philip@balister.org>
Wed, 27 Jan 2010 19:24:08 +0000 (14:24 -0500)
This patch tries to get rid of spew of the useless tar messages durring boot
process on machines without RTC, such as the Beagleboard. Example:

Please wait: booting...
Starting udev
tar: dev/.udev/uevent_seqnum: time stamp 1970-01-01 01:00:21 is 14.122497521 s in the future
tar: dev/.udev/rules.d: time stamp 1970-01-01 01:00:07 is 0.119201623 s in the future
tar: dev/.udev/db/\x2fdevices\x2fvirtual\x2fblock\x2fram9: time stamp 1970-01-01 01:00:22 is 15.118713341 s in the future

[ more then 100 similar lines cutted off]

Signed-off-by: Petr Štetiar <ynezz@true.cz>
Acked-by: Chris Larson <clarson@mvista.com>
Signed-off-by: Philip Balister <philip@balister.org>
recipes/udev/udev-141/init
recipes/udev/udev_141.bb

index 24ca9d8..66705e6 100644 (file)
@@ -44,7 +44,7 @@ if [ "$DEVCACHE" != "" ]; then
           cmp -s /tmp/uname /etc/udev/saved.uname && \
           cmp -s /tmp/cmdline /etc/udev/saved.cmdline && \
           cmp -s /tmp/atags /etc/udev/saved.atags; then
-               (cd /; tar xf $DEVCACHE)
+               (cd /; tar xf $DEVCACHE > /dev/null 2>&1)
                not_first_boot=1
        fi
 fi
index df5e346..d1fee30 100644 (file)
@@ -6,7 +6,7 @@ LICENSE = "GPL"
 # Untested
 DEFAULT_PREFERENCE = "-1"
 
-PR = "r20"
+PR = "r21"
 
 # needed for init.d script
 RDEPENDS_${PN} += "udev-utils"