vala-native: bump to 0.6.0 and make git version the default; we need a bootstrap...
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>
Tue, 7 Apr 2009 09:20:01 +0000 (11:20 +0200)
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>
Tue, 7 Apr 2009 09:20:01 +0000 (11:20 +0200)
conf/distro/include/sane-srcrevs.inc
recipes/vala/vala-bootstrap-native_0.6.0.bb [new file with mode: 0644]
recipes/vala/vala-native_0.5.7.bb [deleted file]
recipes/vala/vala-native_git.bb
recipes/vala/vala_0.5.7.bb [deleted file]
recipes/vala/vala_0.6.0.bb [new file with mode: 0644]

index eb42b33..cf66f00 100644 (file)
@@ -243,7 +243,7 @@ SRCREV_pn-uclibc-initial ?= "25712"
 SRCREV_pn-usbpath ?= "3172"
 SRCREV_pn-usbpath-native ?= "3172"
 SRCREV_pn-vala-terminal ?= "94117f453ce884e9c30b611fae6fc19f85f98f2b"
-SRCREV_pn-vala-native ?= "54a924505856a839ad02dc95baa482e994e94a57"
+SRCREV_pn-vala-native ?= "6cf030120cd7f6a76a5d766d7420aea847e02cfd"
 SRCREV_pn-webkit-gtk ?= "42127"
 SRCREV_pn-wlan-ng-modules ?= "1859"
 SRCREV_pn-wlan-ng-utils ?= "1859"
diff --git a/recipes/vala/vala-bootstrap-native_0.6.0.bb b/recipes/vala/vala-bootstrap-native_0.6.0.bb
new file mode 100644 (file)
index 0000000..bc99ebf
--- /dev/null
@@ -0,0 +1,4 @@
+require vala_${PV}.bb
+
+inherit native
+DEPENDS = "glib-2.0-native"
diff --git a/recipes/vala/vala-native_0.5.7.bb b/recipes/vala/vala-native_0.5.7.bb
deleted file mode 100644 (file)
index 735c93f..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-require vala_${PV}.bb
-
-inherit native
-DEPENDS = "glib-2.0-native"
-
-# work around timestamp problem in tarball
-do_compile_prepend() {
-       touch gobject/gobject.vala.stamp
-}
-    
index 66abd5e..545849b 100644 (file)
@@ -1,17 +1,13 @@
-require vala_0.5.7.bb
-# vala from git always needs the latest released version to compile itself
-DEPENDS = "vala-native"
-
-SRCREV = "e7462e3ed00b75c16c11c27f6d8a640c7f35fafc"
-PV := "0.5.7+0.5.8pre02-gitr${SRCREV}"
+require vala.inc
+inherit native
 
-DEFAULT_PREFERENCE = "-1"
+DEPENDS = "glib-2.0-native"
+# vala from git always needs the latest released version to compile itself
+DEPENDS += "vala-bootstrap-native"
+PV = "0.6.0-fso1-gitr${SRCREV}"
 
 SRC_URI = "\
-  ${FREESMARTPHONE_GIT}/vala;protocol=git;branch=master \
+  ${FREESMARTPHONE_GIT}/vala-lang;protocol=git;branch=mickey/0.6/posix \
   file://static-dbus-methods.patch;patch=1 \
 "         
 S = "${WORKDIR}/git"
-
-inherit native
-DEPENDS = "glib-2.0-native"
diff --git a/recipes/vala/vala_0.5.7.bb b/recipes/vala/vala_0.5.7.bb
deleted file mode 100644 (file)
index 7b2b4e2..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-require vala.inc
-PR = "r2"
diff --git a/recipes/vala/vala_0.6.0.bb b/recipes/vala/vala_0.6.0.bb
new file mode 100644 (file)
index 0000000..7b2b4e2
--- /dev/null
@@ -0,0 +1,2 @@
+require vala.inc
+PR = "r2"