python-openmoko: make it build on amd64
authorMarcin Juszkiewicz <hrw@openembedded.org>
Thu, 23 Aug 2007 08:27:18 +0000 (08:27 +0000)
committerMarcin Juszkiewicz <hrw@openembedded.org>
Thu, 23 Aug 2007 08:27:18 +0000 (08:27 +0000)
packages/python/python-openmoko/.mtn2git_empty [new file with mode: 0644]
packages/python/python-openmoko/python-path.patch [new file with mode: 0644]
packages/python/python-openmoko_0.1.bb

diff --git a/packages/python/python-openmoko/.mtn2git_empty b/packages/python/python-openmoko/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/python/python-openmoko/python-path.patch b/packages/python/python-openmoko/python-path.patch
new file mode 100644 (file)
index 0000000..f43260c
--- /dev/null
@@ -0,0 +1,21 @@
+--- python.orig/m4/python.m4
++++ python/m4/python.m4
+@@ -43,12 +43,18 @@
+ [AC_REQUIRE([AM_PATH_PYTHON])
+ AC_MSG_CHECKING(for headers required to compile python extensions)
+ dnl deduce PYTHON_INCLUDES
++AC_ARG_WITH(python-includes,
++      [  --with-python-includes=DIR  path to Python includes], py_exec_prefix=$withval)
++if test x$py_exec_prefix != x; then
++PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
++else
+ py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
+ py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
+ PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
+ if test "$py_prefix" != "$py_exec_prefix"; then
+   PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
+ fi
++fi
+ AC_SUBST(PYTHON_INCLUDES)
+ dnl check if the headers exist:
+ save_CPPFLAGS="$CPPFLAGS"
index 343a79a..e193f0f 100644 (file)
@@ -3,11 +3,13 @@ AUTHOR = "Holger 'Zecke' Freyther"
 LICENSE = "LGPL"
 DEPENDS = "python-pygtk libmokoui2 libmokojournal2 libmokogsmd2"
 SECTION = "devel/python"
+PR = "r1"
+
+SRC_URI = "svn://svn.projects.openmoko.org/svnroot/bindings;module=python;proto=http \
+          file://python-path.patch;patch=1"
 
-SRC_URI = "svn://svn.projects.openmoko.org/svnroot/bindings;module=python;proto=http"
 S = "${WORKDIR}/python"
 
 inherit autotools distutils-base
 
-
-
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"