re-add some opendreambox related gstreamer customizations I dropped during merge
authorMoritz Venn <moritz.venn@freaque.net>
Fri, 24 Apr 2009 15:58:59 +0000 (17:58 +0200)
committerMoritz Venn <moritz.venn@freaque.net>
Fri, 24 Apr 2009 15:58:59 +0000 (17:58 +0200)
recipes/gstreamer/gst-plugins-bad_0.10.10.bb
recipes/gstreamer/gst-plugins-base_0.10.22.bb

index 85a78ac..a61baaa 100644 (file)
@@ -1,5 +1,7 @@
 require gst-plugins.inc
 
+PR = "r1"
+
 do_configure_prepend() {
        sed -i -e s:docs::g Makefile.am
 }
@@ -11,3 +13,5 @@ DEPENDS += "gst-plugins-base"
 
 EXTRA_OECONF_opendreambox += "--disable-apexsink --disable-dvdnav "
 
+RCONFLICTS_gst-plugin-mpegdemux = "gst-plugin-fluendo-mpegdemux"
+RREPLACES_gst-plugin-mpegdemux = "gst-plugin-fluendo-mpegdemux"
index 3086d93..e39fb98 100644 (file)
@@ -1,12 +1,16 @@
 require gst-plugins.inc
 
+SRC_URI += "file://samihack.patch;patch=1"
+
 PROVIDES += "gst-plugins"
 
 PR = "r2"
 
+EXTRA_OECONF += "--with-audioresample-format=int"
+
 # gst-plugins-base only builds the alsa plugin
 # if alsa has been built and is present.  You will
 # not get an error if this is not present, just 
 # a missing alsa plugin
-DEPENDS += "libtheora alsa-lib libsm virtual/libx11 freetype gnome-vfs libxv"
+DEPENDS += "libtheora alsa-lib freetype"