glibc: Add support for compiling glibc with march=i686
authorDenys Dmytriyenko <denis@denix.org>
Fri, 7 Nov 2008 05:51:50 +0000 (21:51 -0800)
committerKhem Raj <raj.khem@gmail.com>
Fri, 7 Nov 2008 05:51:50 +0000 (21:51 -0800)
packages/glibc/files/march-i686.patch [new file with mode: 0644]
packages/glibc/glibc_2.6.1.bb

diff --git a/packages/glibc/files/march-i686.patch b/packages/glibc/files/march-i686.patch
new file mode 100644 (file)
index 0000000..0461603
--- /dev/null
@@ -0,0 +1,38 @@
+2007-02-15  Khem Raj  <kraj@xxxxxxxxxx>
+
+       * sysdeps/unix/sysv/linux/i386/sysdep.h: Re-define __i686.
+       * nptl/sysdeps/pthread/pt-initfini.c: Ditto.
+
+
+
+Index: sysdeps/unix/sysv/linux/i386/sysdep.h
+===================================================================
+--- sysdeps/unix/sysv/linux/i386/sysdep.h      (revision 1469)
++++ sysdeps/unix/sysv/linux/i386/sysdep.h      (working copy)
+@@ -29,6 +29,10 @@
+ #include <dl-sysdep.h>
+ #include <tls.h>
++#if defined __i686 && defined __ASSEMBLER__
++#undef __i686
++#define __i686 __i686
++#endif
+ /* For Linux we can use the system call table in the header file
+       /usr/include/asm/unistd.h
+Index: nptl/sysdeps/pthread/pt-initfini.c
+===================================================================
+--- nptl/sysdeps/pthread/pt-initfini.c (revision 1469)
++++ nptl/sysdeps/pthread/pt-initfini.c (working copy)
+@@ -45,6 +45,11 @@
+ /* Embed an #include to pull in the alignment and .end directives. */
+ asm ("\n#include \"defs.h\"");
++asm ("\n#if defined __i686 && defined __ASSEMBLER__");
++asm ("\n#undef __i686");
++asm ("\n#define __i686 __i686");
++asm ("\n#endif");
++
+ /* The initial common code ends here. */
+ asm ("\n/*@HEADER_ENDS*/");
index 1705017..ab343ea 100644 (file)
@@ -58,6 +58,7 @@ SRC_URI = "\
   file://glibc-use-isystem-include-fixed.patch;patch=1 \
   file://glibc-arm-no-asm-page.patch;patch=1 \
   file://armv4t-interworking.patch;patch=1 \
+  file://march-i686.patch;patch=1;pnum=0 \
 "
 
 # Build fails on sh3 and sh4 without additional patches