directfb: Add 1.2.7
authorTom Rini <trini@embeddedalley.com>
Wed, 4 Feb 2009 19:54:11 +0000 (14:54 -0500)
committerTom Rini <trini@embeddedalley.com>
Wed, 4 Feb 2009 19:54:11 +0000 (14:54 -0500)
We move the 1.2.3 fix-pkgconfig-cflags patch to files and rename and
we have to refresh ts_lib_autotools.patch for 1.2.7

conf/checksums.ini
packages/directfb/directfb-1.2.3/fix-pkgconfig-cflags.patch [deleted file]
packages/directfb/directfb-1.2.7/ts_lib_autotools.patch [new file with mode: 0644]
packages/directfb/directfb_1.2.3.bb
packages/directfb/directfb_1.2.7.bb [new file with mode: 0644]
packages/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch [new file with mode: 0644]

index a124644..691f7eb 100644 (file)
@@ -186,6 +186,10 @@ sha256=f12ec5f0864d85268a8d67e4919cb7f3d7f0e06ed6cc278c952f6c342673d931
 md5=caea8bcfc9c1d391e56d85e437005a5d
 sha256=0875e553a17fe65e920ad810a67aa6faca582c53476d8dc75880a6b3da625d0b
 
+[http://directfb.org/downloads/Core/DirectFB-1.2.7.tar.gz]
+md5=59ca16f600e96c8c104a485ff7c322c6
+sha256=80ab8e34246a280bc380020cf331bcc0014cf816380cee3935ad455c108e661e
+
 [http://www.directfb.org/downloads/Extras/DirectFB-examples-0.9.25.tar.gz]
 md5=835e850fddba8d8214d39ddd0646c3e8
 sha256=f83af60d53ab4319e5d71a4459cc10464ffd683efabacd6bd773bb807f8771fa
diff --git a/packages/directfb/directfb-1.2.3/fix-pkgconfig-cflags.patch b/packages/directfb/directfb-1.2.3/fix-pkgconfig-cflags.patch
deleted file mode 100644 (file)
index 745c561..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-Index: DirectFB-1.1.1/directfb-internal.pc.in
-===================================================================
---- DirectFB-1.1.1.orig/directfb-internal.pc.in        2007-08-07 21:43:00.000000000 +0200
-+++ DirectFB-1.1.1/directfb-internal.pc.in     2008-07-17 21:00:47.424654304 +0200
-@@ -2,10 +2,10 @@
- exec_prefix=@exec_prefix@
- moduledir=@MODULEDIR@
- moduledirname=@MODULEDIRNAME@
--includedir=@INTERNALINCLUDEDIR@
-+includedir=@includedir@
- Name: DirectFB-Internal
- Description: Third party module support package for DirectFB.
- Version: @VERSION@
- Requires: directfb = @VERSION@
--Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
-+Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir}/directfb -I${includedir}
-Index: DirectFB-1.1.1/directfb.pc.in
-===================================================================
---- DirectFB-1.1.1.orig/directfb.pc.in 2007-12-15 16:23:16.000000000 +0100
-+++ DirectFB-1.1.1/directfb.pc.in      2008-07-17 20:59:58.044985193 +0200
-@@ -9,4 +9,4 @@
- Requires: fusion direct
- Libs: -L${libdir} -ldirectfb @THREADLIB@ @OSX_LIBS@
- Libs.private: -L${libdir} @DYNLIB@ @ZLIB_LIBS@
--Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
-+Cflags: @THREADFLAGS@ -I${includedir}/directfb
-Index: DirectFB-1.1.1/lib/fusion/fusion.pc.in
-===================================================================
---- DirectFB-1.1.1.orig/lib/fusion/fusion.pc.in        2007-08-07 21:43:00.000000000 +0200
-+++ DirectFB-1.1.1/lib/fusion/fusion.pc.in     2008-07-17 20:58:07.051338866 +0200
-@@ -8,4 +8,4 @@
- Version: @VERSION@
- Requires: direct
- Libs: -L${libdir} -lfusion
--Cflags: -I@INCLUDEDIR@
-+Cflags: -I${includedir}/directfb -I${includedir}
-Index: DirectFB-1.1.1/lib/voodoo/voodoo.pc.in
-===================================================================
---- DirectFB-1.1.1.orig/lib/voodoo/voodoo.pc.in        2007-08-07 21:43:00.000000000 +0200
-+++ DirectFB-1.1.1/lib/voodoo/voodoo.pc.in     2008-07-17 20:58:07.054671842 +0200
-@@ -8,4 +8,4 @@
- Version: @VERSION@
- Requires: direct
- Libs: -L${libdir} -lvoodoo
--Cflags: -I@INCLUDEDIR@
-+Cflags: -I${includedir}/directfb -I${includedir}
diff --git a/packages/directfb/directfb-1.2.7/ts_lib_autotools.patch b/packages/directfb/directfb-1.2.7/ts_lib_autotools.patch
new file mode 100644 (file)
index 0000000..f19c724
--- /dev/null
@@ -0,0 +1,22 @@
+---
+ configure.in |    7 +++++--
+ 1 file changed, 5 insertions(+), 2 deletions(-)
+
+Index: DirectFB-1.2.7/configure.in
+===================================================================
+--- DirectFB-1.2.7.orig/configure.in
++++ DirectFB-1.2.7/configure.in
+@@ -1288,8 +1288,11 @@ fi
+ enable_tslib=no
+ if test "$checkfor_tslib" = "yes"; then
+-  PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [enable_tslib=yes], [enable_tslib=no,
+-    AC_MSG_WARN([*** no tslib -- tslib driver will not be built.])])
++  PKG_CHECK_MODULES([TSLIB], [tslib-1.0 >= 1.0.0], [enable_tslib=yes], [enable_tslib=no])
++  if test "$enable_tslib" = "no"; then
++    PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [enable_tslib=yes], [enable_tslib=no,
++      AC_MSG_WARN([*** no tslib -- tslib driver will not be built.])])
++  fi
+ fi
+ enable_ucb1x00_ts=no
index 85e42a1..e4d50a3 100644 (file)
@@ -1,13 +1,13 @@
 require directfb.inc
 
 RV = "1.2-0"
-PR = "r0"
+PR = "r1"
 
 DEPENDS += "sysfsutils"
 
 SRC_URI = " \
     http://www.directfb.org/downloads/Old/DirectFB-${PV}.tar.gz \
-    file://fix-pkgconfig-cflags.patch;patch=1 \
+    file://directfb-1.2.x-fix-pkgconfig-cflags.patch;patch=1 \
     file://mkdfiff.patch;patch=1 \
     file://dont-use-linux-config.patch;patch=1 \
     file://ts_lib_autotools.patch;patch=1 \
diff --git a/packages/directfb/directfb_1.2.7.bb b/packages/directfb/directfb_1.2.7.bb
new file mode 100644 (file)
index 0000000..be6a6da
--- /dev/null
@@ -0,0 +1,28 @@
+require directfb.inc
+
+RV = "1.2-0"
+PR = "r0"
+
+DEPENDS += "sysfsutils"
+
+SRC_URI = " \
+    http://directfb.org/downloads/Core/DirectFB-${PV}.tar.gz \
+    file://directfb-1.2.x-fix-pkgconfig-cflags.patch;patch=1 \
+    file://mkdfiff.patch;patch=1 \
+    file://dont-use-linux-config.patch;patch=1 \
+    file://ts_lib_autotools.patch;patch=1 \
+"
+
+EXTRA_OECONF = "\
+  --enable-freetype=yes \
+  --enable-zlib \
+  --with-gfxdrivers=none \
+  --disable-libmpeg3 \
+  --disable-sdl \
+  --disable-vnc \
+  --disable-x11 \
+"
+
+LDFLAGS_append = ""
+
+LEAD_SONAME = "libdirectfb-1.2.so.0"
diff --git a/packages/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch b/packages/directfb/files/directfb-1.2.x-fix-pkgconfig-cflags.patch
new file mode 100644 (file)
index 0000000..745c561
--- /dev/null
@@ -0,0 +1,47 @@
+Index: DirectFB-1.1.1/directfb-internal.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/directfb-internal.pc.in        2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.1/directfb-internal.pc.in     2008-07-17 21:00:47.424654304 +0200
+@@ -2,10 +2,10 @@
+ exec_prefix=@exec_prefix@
+ moduledir=@MODULEDIR@
+ moduledirname=@MODULEDIRNAME@
+-includedir=@INTERNALINCLUDEDIR@
++includedir=@includedir@
+ Name: DirectFB-Internal
+ Description: Third party module support package for DirectFB.
+ Version: @VERSION@
+ Requires: directfb = @VERSION@
+-Cflags: @DFB_INTERNAL_CFLAGS@ -I@INTERNALINCLUDEDIR@
++Cflags: @DFB_INTERNAL_CFLAGS@ -I${includedir}/directfb -I${includedir}
+Index: DirectFB-1.1.1/directfb.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/directfb.pc.in 2007-12-15 16:23:16.000000000 +0100
++++ DirectFB-1.1.1/directfb.pc.in      2008-07-17 20:59:58.044985193 +0200
+@@ -9,4 +9,4 @@
+ Requires: fusion direct
+ Libs: -L${libdir} -ldirectfb @THREADLIB@ @OSX_LIBS@
+ Libs.private: -L${libdir} @DYNLIB@ @ZLIB_LIBS@
+-Cflags: @THREADFLAGS@ -I@INCLUDEDIR@
++Cflags: @THREADFLAGS@ -I${includedir}/directfb
+Index: DirectFB-1.1.1/lib/fusion/fusion.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/lib/fusion/fusion.pc.in        2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.1/lib/fusion/fusion.pc.in     2008-07-17 20:58:07.051338866 +0200
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lfusion
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb -I${includedir}
+Index: DirectFB-1.1.1/lib/voodoo/voodoo.pc.in
+===================================================================
+--- DirectFB-1.1.1.orig/lib/voodoo/voodoo.pc.in        2007-08-07 21:43:00.000000000 +0200
++++ DirectFB-1.1.1/lib/voodoo/voodoo.pc.in     2008-07-17 20:58:07.054671842 +0200
+@@ -8,4 +8,4 @@
+ Version: @VERSION@
+ Requires: direct
+ Libs: -L${libdir} -lvoodoo
+-Cflags: -I@INCLUDEDIR@
++Cflags: -I${includedir}/directfb -I${includedir}