gnutls: fixing the pkgconfig is not necessary for gnutls 2.4.2
authorJeremy Lainé <jeremy.laine@m4x.org>
Fri, 24 Oct 2008 10:44:44 +0000 (12:44 +0200)
committerJeremy Lainé <jeremy.laine@m4x.org>
Fri, 24 Oct 2008 10:44:44 +0000 (12:44 +0200)
packages/gnutls/gnutls.inc
packages/gnutls/gnutls_1.4.5.bb
packages/gnutls/gnutls_1.6.3.bb
packages/gnutls/gnutls_2.4.2.bb

index 6400e80..e438423 100644 (file)
@@ -9,11 +9,6 @@ inherit autotools binconfig pkgconfig
 
 EXTRA_OECONF = "--with-included-opencdk --with-included-libtasn1"
 
-# fix wrong dependency
-do_configure_prepend() {
-    sed -i s,gcrypt,libgcrypt, lib/gnutls.pc.in
-}
-
 do_stage() {
     oe_libinstall -C lib/.libs -so -a libgnutls ${STAGING_LIBDIR}
     oe_libinstall -C libextra/.libs -so -a libgnutls-extra ${STAGING_LIBDIR}
index 749064a..a5e5873 100644 (file)
@@ -1,3 +1,8 @@
 require gnutls.inc
 
+# fix wrong dependency
+do_configure_prepend() {
+    sed -i s,gcrypt,libgcrypt, lib/gnutls.pc.in
+}
+
 PR = "r3"
index ce10a4b..7a89835 100644 (file)
@@ -6,4 +6,9 @@ SRC_URI += "\
        file://configure_madness.patch;patch=1 \
        "
 
+# fix wrong dependency
+do_configure_prepend() {
+    sed -i s,gcrypt,libgcrypt, lib/gnutls.pc.in
+}
+
 PR = "r6"
index 3313a45..15614fb 100644 (file)
@@ -5,3 +5,5 @@ SRC_URI += "\
        file://gnutls-texinfo-euro.patch;patch=1 \
        file://configure_madness.patch;patch=1 \
        "
+
+PR = "r1"