enigma2: workaround for opkg <= 0.1.7+svnr455-r19.1, which caused tuxtxt.ttf to get...
authorAndreas Oberritter <obi@opendreambox.org>
Mon, 22 Nov 2010 23:21:30 +0000 (23:21 +0000)
committerAndreas Oberritter <obi@opendreambox.org>
Mon, 22 Nov 2010 23:21:30 +0000 (23:21 +0000)
recipes/enigma2/enigma2.bb [changed mode: 0755->0644]

old mode 100755 (executable)
new mode 100644 (file)
index beba1fa..84740fa
@@ -59,7 +59,7 @@ RDEPENDS_enigma2-plugin-systemplugins-wirelesslan = "wpa-supplicant wireless-too
 DESCRIPTION_append_enigma2-plugin-systemplugins-networkwizard = "provides easy step by step network configuration"
 
 PN = "enigma2"
-PR = "r1"
+PR = "r2"
 
 SRCDATE = "20101117"
 #SRCDATE is NOT used by git to checkout a specific revision
@@ -100,3 +100,21 @@ python populate_packages_prepend () {
 
 RCONFLICTS_${PN} = "dreambox-keymaps"
 RREPLACES_${PN} = "dreambox-keymaps tuxbox-tuxtxt-32bpp (<= 0.0+cvs20090130-r1)"
+
+# workaround for opkg <= 0.1.7+svnr455-r19.1
+pkg_preinst_${PN} () {
+       if [ "x$D" != "x" ]; then
+               exit 1
+       fi
+       if [ -f ${datadir}/fonts/tuxtxt.ttf ]; then
+               cp -a ${datadir}/fonts/tuxtxt.ttf /tmp/tuxtxt.ttf
+       fi
+}
+pkg_postinst_${PN} () {
+       if [ "x$D" != "x" ]; then
+               exit 1
+       fi
+       if [ -f /tmp/tuxtxt.ttf -a ! -f ${datadir}/fonts/tuxtxt.ttf ]; then
+               mv /tmp/tuxtxt.ttf ${datadir}/fonts/tuxtxt.ttf
+       fi
+}