packages/images/minimal-image.bb : Add a minimal-image that contains only the nessesa...
authorStelios Koroneos <skoroneos@digital-opsis.com>
Sat, 12 May 2007 18:40:19 +0000 (18:40 +0000)
committerStelios Koroneos <skoroneos@digital-opsis.com>
Sat, 12 May 2007 18:40:19 +0000 (18:40 +0000)
and an ssh daemon for systems with limited flash resources

packages/images/minimal-image.bb [new file with mode: 0644]

diff --git a/packages/images/minimal-image.bb b/packages/images/minimal-image.bb
new file mode 100644 (file)
index 0000000..235cdbc
--- /dev/null
@@ -0,0 +1,22 @@
+#Create a minimal image for devices with little flash
+#gives you a small images with ssh access
+LICENSE = "MIT"
+PR = "r0"
+
+ANGSTROM_EXTRA_INSTALL ?= ""
+DISTRO_SSH_DAEMON ?= "dropbear"
+
+DEPENDS = "task-base \
+           ${DISTRO_SSH_DAEMON} \
+         "
+
+RDEPENDS = "task-boot \
+            ${DISTRO_SSH_DAEMON} \
+          "
+
+export IMAGE_BASENAME = "minimal-image"
+export IMAGE_LINGUAS = ""
+export PACKAGE_INSTALL = "${RDEPENDS}"
+
+inherit image
+