directfb: Remove potential dangerous sed invocation. Add a -I in front and replace...
authorHolger Freyther <zecke@selfish.org>
Wed, 12 Mar 2008 10:35:31 +0000 (10:35 +0000)
committerHolger Freyther <zecke@selfish.org>
Wed, 12 Mar 2008 10:35:31 +0000 (10:35 +0000)
    It is still compiling and packaging.

packages/directfb/++dfb_1.0.0.bb
packages/directfb/directfb-examples_1.0.0.bb

index f440e11..020cbfe 100644 (file)
@@ -11,7 +11,7 @@ RV = "0.9-25"
 inherit autotools pkgconfig
 
 do_configure_append() {
-    find ${S} -type f | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
+    find ${S} -type f | xargs sed -i 's:-I/usr/include::g'
 }
 
 do_stage() {
index 064a808..e59e4ec 100644 (file)
@@ -11,8 +11,8 @@ S = "${WORKDIR}/DirectFB-examples-${PV}"
 inherit autotools
 
 do_configure_append() {
-#    find ${S} -type f | xargs sed -i 's:/usr/lib:${STAGING_LIBDIR}:'
-    find ${S} -type f | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
+#    find ${S} -type f | xargs sed -i 's:-L/usr/lib::g'
+    find ${S} -type f | xargs sed -i 's:-I/usr/include::g'
 }
 
 do_stage() {