hal: create volatiles *after* creating the haldaemon user
authorJeremy Laine <jeremy.laine@m4x.org>
Wed, 2 Jul 2008 17:18:59 +0000 (17:18 +0000)
committerJeremy Laine <jeremy.laine@m4x.org>
Wed, 2 Jul 2008 17:18:59 +0000 (17:18 +0000)
packages/hal/hal_0.5.9.1.bb
packages/hal/hal_0.5.9.bb
packages/hal/hal_git.bb

index 3d2ba15..8bd193c 100644 (file)
@@ -7,7 +7,7 @@ DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat libusb-compat"
 RDEPENDS_${PN} += "udev hal-info"
 RRECOMMENDS_${PN} += "udev-utils"
 
-PR = "r7"
+PR = "r8"
 
 SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
            file://configure_fix.patch;patch=1 \
@@ -52,11 +52,11 @@ pkg_postinst_hal () {
                exit 1
        fi
 
-       /etc/init.d/populate-volatile.sh update
-
        grep haldaemon /etc/group || addgroup haldaemon
        grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
 
+       /etc/init.d/populate-volatile.sh update
+
        DBUSPID=`pidof dbus-daemon`
 
        if [ "x$DBUSPID" != "x" ]; then
index b878638..8dabddf 100644 (file)
@@ -5,7 +5,7 @@ RDEPENDS += "udev hal-info"
 #RDEPENDS_hal-device-manager = "python hal python-pygnome"
 RRECOMMENDS = "udev-utils"
 
-PR = "r7"
+PR = "r8"
 
 SRC_URI += "file://99_hal \
             file://20hal \
@@ -53,11 +53,11 @@ pkg_postinst_hal () {
                exit 1
        fi
 
-       /etc/init.d/populate-volatile.sh update
-
        grep haldaemon /etc/group || addgroup haldaemon
        grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
 
+       /etc/init.d/populate-volatile.sh update
+
        DBUSPID=`pidof dbus-daemon`
 
        if [ "x$DBUSPID" != "x" ]; then
index 659ab8e..49ecfde 100644 (file)
@@ -14,7 +14,7 @@ SRC_URI = "git://anongit.freedesktop.org/hal/;protocol=git \
         file://99_hal"
 
 PV = "0.5.9.1+git${SRCDATE}"
-PR = "r5"
+PR = "r6"
 
 S = "${WORKDIR}/git"
 
@@ -53,11 +53,11 @@ pkg_postinst_hal () {
                exit 1
        fi
 
-       /etc/init.d/populate-volatile.sh update
-
        grep haldaemon /etc/group || addgroup haldaemon
        grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
 
+       /etc/init.d/populate-volatile.sh update
+
        DBUSPID=`pidof dbus-daemon`
 
        if [ "x$DBUSPID" != "x" ]; then