openobex: add 1.5
authorKoen Kooi <koen@openembedded.org>
Sun, 12 Apr 2009 08:34:15 +0000 (10:34 +0200)
committerKoen Kooi <koen@openembedded.org>
Sun, 12 Apr 2009 08:34:15 +0000 (10:34 +0200)
conf/checksums.ini
recipes/openobex/openobex-1.5/libusb_crosscompile_check.patch [new file with mode: 0644]
recipes/openobex/openobex_1.5.bb [new file with mode: 0644]

index 3718ba6..65ab2f2 100644 (file)
@@ -17410,6 +17410,10 @@ sha256=3a80ba2524c66a46db3ac17a788a759015a1f79de6a495fcdf3a316e19fe7c23
 md5=feaa5dfe5151c0e70e8f868fa4648a43
 sha256=3a80ba2524c66a46db3ac17a788a759015a1f79de6a495fcdf3a316e19fe7c23
 
+[http://www.kernel.org/pub/linux/bluetooth/openobex-1.5.tar.gz]
+md5=0d83dc86445a46a1b9750107ba7ab65c
+sha256=e602047570799a47ecb028420bda8f2cef41310e5a99d084de10aa9422935e65
+
 [http://www.openpbx.org/releases/openpbx.org-1.2_rc3.tar.gz]
 md5=e270c40626dfa2131cc39dd1352b46f9
 sha256=934e1e5438c46927236f1f3254265e94c7e38e7c0e02d92abb7efc4e03ce91e9
diff --git a/recipes/openobex/openobex-1.5/libusb_crosscompile_check.patch b/recipes/openobex/openobex-1.5/libusb_crosscompile_check.patch
new file mode 100644 (file)
index 0000000..1177dfe
--- /dev/null
@@ -0,0 +1,11 @@
+--- /tmp/acinclude.m4  2009-04-12 10:32:15.000000000 +0200
++++ openobex-1.5/acinclude.m4  2009-04-12 10:32:38.000000000 +0200
+@@ -158,7 +158,7 @@
+               ;;
+       *)
+               PKG_CHECK_MODULES(USB, libusb, usb_lib_found=yes, AC_MSG_RESULT(no))
+-              AC_CHECK_FILE(${prefix}/lib/pkgconfig/libusb.pc, REQUIRES="libusb")
++              REQUIRES="libusb"
+               ;;
+       esac
+       AC_SUBST(USB_CFLAGS)
diff --git a/recipes/openobex/openobex_1.5.bb b/recipes/openobex/openobex_1.5.bb
new file mode 100644 (file)
index 0000000..ab69cf1
--- /dev/null
@@ -0,0 +1,22 @@
+DESCRIPTION = "The Openobex project is an open source implementation of the \
+Object Exchange (OBEX) protocol."
+HOMEPAGE = "http://openobex.triq.net"
+SECTION = "libs"
+PROVIDES = "openobex-apps"
+DEPENDS = "libusb-compat bluez4"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/openobex-${PV}.tar.gz \
+           file://disable-cable-test.patch;patch=1 \
+           file://libusb_crosscompile_check.patch;patch=1"
+
+inherit autotools_stage binconfig pkgconfig
+
+EXTRA_OECONF = "--enable-apps --enable-syslog --enable-dump \
+                --with-usb=${STAGING_LIBDIR}/.. --with-bluez=${STAGING_LIBDIR}/.."
+
+PACKAGES += "openobex-apps"
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/openobex-config"
+FILES_${PN}-apps = "${bindir}/*"
+DEBIAN_NOAUTONAME_${PN}-apps = "1"