better handling for dreambox-passthrough..
authorghost <andreas.monzner@multimedia-labs.de>
Thu, 17 Feb 2011 14:56:23 +0000 (15:56 +0100)
committerghost <andreas.monzner@multimedia-labs.de>
Thu, 17 Feb 2011 17:32:07 +0000 (18:32 +0100)
conf/machine/dm500hd.conf
conf/machine/dm7020hd.conf
conf/machine/dm8000.conf
conf/machine/dm800se.conf
recipes/enigma2/enigma2.bb
recipes/tasks/task-opendreambox-enigma2.bb

index d141c02..70f1f70 100644 (file)
@@ -79,6 +79,6 @@ IMAGE_CMD_jffs2 = "\
 GLIBC_EXTRA_OECONF = "--disable-profile --with-tls --with-__thread"
 TARGET_FPU = "hard"
 
-MACHINE_FEATURES += "modem wifi"
+MACHINE_FEATURES += "modem wifi dreambox-libpassthrough"
 
 require conf/machine/include/dreambox-mipsel.inc
index fdbbb5c..07e6211 100644 (file)
@@ -81,6 +81,6 @@ IMAGE_CMD_jffs2 = "\
 GLIBC_EXTRA_OECONF = "--disable-profile --with-tls --with-__thread"
 TARGET_FPU = "hard"
 
-MACHINE_FEATURES += "modem wifi"
+MACHINE_FEATURES += "modem wifi dreambox-libpassthrough"
 
 require conf/machine/include/dreambox-mipsel.inc
index 99f7251..67df82d 100644 (file)
@@ -87,7 +87,7 @@ IMAGE_CMD_jffs2 = "\
 GLIBC_EXTRA_OECONF = "--disable-profile --with-tls --with-__thread"
 TARGET_FPU = "hard"
 
-MACHINE_FEATURES += "wifi"
+MACHINE_FEATURES += "wifi dreambox-libpassthrough"
 
 require conf/machine/include/dreambox-mipsel.inc
 
index e670064..f70ed08 100644 (file)
@@ -81,6 +81,6 @@ IMAGE_CMD_jffs2 = "\
 GLIBC_EXTRA_OECONF = "--disable-profile --with-tls --with-__thread"
 TARGET_FPU = "hard"
 
-MACHINE_FEATURES += "modem wifi"
+MACHINE_FEATURES += "modem wifi dreambox-libpassthrough"
 
 require conf/machine/include/dreambox-mipsel.inc
index ad32733..50d98d8 100644 (file)
@@ -24,10 +24,10 @@ GST_BASE_RDEPENDS = "${GST_ALSA_RDEPENDS} ${GST_MISC_RDEPENDS} ${GST_RTSP_RDEPEN
 RDEPENDS_append_dm7020 = " gst-plugin-ossaudio gst-plugin-ivorbisdec"
 RDEPENDS_append_dm7025 = " ${GST_ALSA_RDEPENDS} gst-plugin-ivorbisdec"
 RDEPENDS_append_dm800 = " ${GST_BASE_RDEPENDS} gst-plugin-ivorbisdec"
-RDEPENDS_append_dm8000 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi libpassthrough"
-RDEPENDS_append_dm500hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi libpassthrough"
-RDEPENDS_append_dm800se = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi libpassthrough"
-RDEPENDS_append_dm7020hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi libpassthrough"
+RDEPENDS_append_dm8000 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
+RDEPENDS_append_dm500hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
+RDEPENDS_append_dm800se = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
+RDEPENDS_append_dm7020hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
 
 # 'forward depends' - no two providers can have the same PACKAGES_DYNAMIC, however both
 # enigma2 and enigma2-plugins produce enigma2-plugin-*.
@@ -61,13 +61,8 @@ DESCRIPTION_append_enigma2-plugin-systemplugins-networkwizard = "provides easy s
 PN = "enigma2"
 PR = "r0"
 
-DEPENDS_append_dm8000 = " dreambox-libpassthrough"
-DEPENDS_append_dm500hd = " dreambox-libpassthrough"
-DEPENDS_append_dm800se = " dreambox-libpassthrough"
-DEPENDS_append_dm7020hd = " dreambox-libpassthrough"
-
-SRCDATE = "20110216"
-SRCREV = "f157ad52f1bc3be81ccba075aa9218237aa71973"
+SRCDATE = "20110217"
+SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
 #SRCDATE is NOT used by git to checkout a specific revision
 #but we need it to build a ipk package version
 #when you like to checkout a specific revision of e2 you need
index f1b34fe..5e276bd 100755 (executable)
@@ -1,7 +1,7 @@
 DESCRIPTION = "OpenDreambox: Enigma2 Task for the OpenDreambox Distribution"
 SECTION = "opendreambox/base"
 LICENSE = "MIT"
-PR = "r7"
+PR = "r8"
 
 inherit task
 
@@ -14,6 +14,10 @@ PACKAGES = "\
   task-opendreambox-enigma2 \
 "
 
+DEPENDS += "\
+  ${@base_contains("MACHINE_FEATURES", "dreambox-libpassthrough", "dreambox-libpassthrough", "", d)} \
+"
+
 #
 # task-opendreambox-enigma2
 #
@@ -53,6 +57,7 @@ RRECOMMENDS_task-opendreambox-enigma2 = "\
   enigma2-plugin-systemplugins-skinselector \
   ${@base_contains("MACHINE_FEATURES", "wifi", "task-opendreambox-wlan", "", d)} \
   ${@base_contains("MACHINE_FEATURES", "modem", "task-opendreambox-modem", "", d)} \
+  ${@base_contains("MACHINE_FEATURES", "dreambox-libpassthrough", "libpassthrough", "", d)} \
 "
 
 RDEPENDS_task-opendreambox-enigma2_append_dm500hd = "\