fso: add .conf files to CONFFILES, remove .service file for fsogsmd for SHR
authorMartin Jansa <Martin.Jansa@gmail.com>
Mon, 11 Jan 2010 15:21:09 +0000 (16:21 +0100)
committerMartin Jansa <Martin.Jansa@gmail.com>
Mon, 11 Jan 2010 15:55:01 +0000 (16:55 +0100)
* fsogsmd is installed in SHR images only for testing purposes, but
  .service file makes dbus trying to autostart it, which conflicts with
  ogsmd running by default from frameworkd.

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
recipes/freesmartphone/fsodatad_git.bb
recipes/freesmartphone/fsodeviced_git.bb
recipes/freesmartphone/fsogsmd_git.bb
recipes/freesmartphone/fsonetworkd_git.bb
recipes/freesmartphone/fsotdld_git.bb
recipes/freesmartphone/fsousaged_git.bb

index c2933ed..95f50ee 100644 (file)
@@ -1,6 +1,6 @@
 require cornucopia.inc
 inherit fso-plugin
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
 PV = "0.0.0+gitr${SRCREV}"
 
 DEPENDS += "libxml2 mobile-broadband-provider-info"
@@ -13,3 +13,4 @@ do_install_append() {
 }
 
 FILES_${PN} += "${sysconfdir}/freesmartphone/fsodatad.conf"
+CONFFILES_${PN} += "${sysconfdir}/freesmartphone/fsodatad.conf"
index 640f9d9..67e0f77 100644 (file)
@@ -6,7 +6,7 @@ RDEPENDS += "libcanberra-alsa"
 RRECOMMENDS += "fso-alsa-data"
 PV = "0.9.0+gitr${SRCREV}"
 PE = "1"
-PR = "${INC_PR}.7"
+PR = "${INC_PR}.8"
 
 EXTRA_OECONF = "\
   --enable-kernel26-rfkill \
@@ -28,3 +28,4 @@ do_install_append() {
 }
 
 FILES_${PN} += "${sysconfdir}/init.d/fsodeviced ${sysconfdir}/freesmartphone/fsodeviced.conf"
+CONFFILES_${PN} += "${sysconfdir}/freesmartphone/fsodeviced.conf"
index ec46d62..f6adeeb 100644 (file)
@@ -1,6 +1,6 @@
 require cornucopia.inc
 inherit fso-plugin
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
 PV = "0.2.0+gitr${SRCREV}"
 
 DEPENDS += "libfsoresource libgsm0710mux"
@@ -12,4 +12,10 @@ do_install_append() {
        install -m 0644 ${WORKDIR}/fsogsmd.conf ${D}${sysconfdir}/freesmartphone/
 }
 
+do_install_append_shr() {
+       # remove .service file to disable fsogsmd autostart
+       rm -f ${D}${datadir}/dbus-1/system-services/org.freesmartphone.ogsmd.service
+}
+
 FILES_${PN} += "${sysconfdir}/freesmartphone/fsogsmd.conf"
+CONFFILES_${PN} += "${sysconfdir}/freesmartphone/fsogsmd.conf"
index 50adeb8..2faf0a5 100644 (file)
@@ -2,7 +2,7 @@ require cornucopia.inc
 inherit fso-plugin
 DEPENDS += "libnl2"
 PV = "0.1.0.0+gitr${SRCREV}"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
 
 SRC_URI += "file://fsonetworkd.conf"
 
@@ -12,3 +12,4 @@ do_install_append() {
 }
 
 FILES_${PN} += "${sysconfdir}/freesmartphone/fsonetworkd.conf"
+CONFFILES_${PN} += "${sysconfdir}/freesmartphone/fsonetworkd.conf"
index 14659bd..e6b64c3 100644 (file)
@@ -1,6 +1,6 @@
 require cornucopia.inc
 inherit fso-plugin
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
 PV = "0.0.0+gitr${SRCREV}"
 
 DEPENDS += "libfsotransport libfsoresource"
@@ -13,3 +13,4 @@ do_install_append() {
 }
 
 FILES_${PN} += "${sysconfdir}/freesmartphone/fsotdld.conf"
+CONFFILES_${PN} += "${sysconfdir}/freesmartphone/fsotdld.conf"
index 0157df5..649b9e4 100644 (file)
@@ -1,7 +1,7 @@
 require cornucopia.inc
 inherit fso-plugin
 PV = "0.9.0.1+gitr${SRCREV}"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
 
 SRC_URI += "file://fsousaged.conf"
 
@@ -11,3 +11,4 @@ do_install_append() {
 }
 
 FILES_${PN} += "${sysconfdir}/freesmartphone/fsousaged.conf"
+CONFFILES_${PN} += "${sysconfdir}/freesmartphone/fsousaged.conf"