classes/binconfig.bbclass: Allow packages to add sed expressions
authorHolger Freyther <zecke@selfish.org>
Thu, 27 Dec 2007 11:46:52 +0000 (11:46 +0000)
committerHolger Freyther <zecke@selfish.org>
Thu, 27 Dec 2007 11:46:52 +0000 (11:46 +0000)
packages/apr/apr-util,apr: patch the config files to be 'installed' and not point to the build and source-directory.

classes/binconfig.bbclass
packages/apr/apr-util_1.2.7.bb
packages/apr/apr_1.2.7.bb

index 4e425a7..5ce9ff6 100644 (file)
@@ -20,6 +20,8 @@ def get_binconfig_mangle(d):
                s += " -e 's:OEEXECPREFIX:${STAGING_DIR_HOST}${layout_exec_prefix}:'"
                s += " -e 's:-I${WORKDIR}:-I${STAGING_INCDIR}:'"
                s += " -e 's:-L${WORKDIR}:-L${STAGING_LIBDIR}:'"
+               if bb.data.getVar("OE_BINCONFIG_EXTRA_MANGLE", d):
+                   s += bb.data.getVar("OE_BINCONFIG_EXTRA_MANGLE", d)
        return s
 
 BINCONFIG_GLOB ?= "*-config"
index ea81607..1543714 100644 (file)
@@ -14,8 +14,11 @@ EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS} --with-dbm=gdbm \
                --without-sqlite3 \
                --with-expat=${STAGING_DIR_HOST}${layout_prefix}"
 
+
 inherit autotools lib_package binconfig
 
+OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+
 do_configure() {
   oe_runconf
 }
index 2016ca0..d11c1f5 100644 (file)
@@ -9,6 +9,8 @@ SRC_URI = "${APACHE_MIRROR}/apr/${P}.tar.bz2"
 
 inherit autotools lib_package binconfig
 
+OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
+
 do_configure() {
   oe_runconf
 }