opie-bluetoothapplet cvs: Patch to get BT params from /etc/sysconfig/bluetooth
authorPaul Sokolovsky <pmiscml@gmail.com>
Mon, 12 Feb 2007 10:09:52 +0000 (10:09 +0000)
committerPaul Sokolovsky <pmiscml@gmail.com>
Mon, 12 Feb 2007 10:09:52 +0000 (10:09 +0000)
* instead of hardcoding in C++ code.
* Originally by Slavek Banko, http://handhelds.org/hypermail/opie-devel/29/2946.html
* Submitted upstream as http://opie-bugs.oszine.de/view.php?id=1838

packages/opie-bluetoothapplet/files/.mtn2git_empty [new file with mode: 0644]
packages/opie-bluetoothapplet/files/sysconfig-bluetooth.patch [new file with mode: 0644]
packages/opie-bluetoothapplet/opie-bluetoothapplet_cvs.bb

diff --git a/packages/opie-bluetoothapplet/files/.mtn2git_empty b/packages/opie-bluetoothapplet/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/opie-bluetoothapplet/files/sysconfig-bluetooth.patch b/packages/opie-bluetoothapplet/files/sysconfig-bluetooth.patch
new file mode 100644 (file)
index 0000000..83ee765
--- /dev/null
@@ -0,0 +1,40 @@
+--- applet.org/bluezapplet.cpp.org     2007-02-11 16:48:06.000000000 +0000
++++ applet/bluezapplet.cpp     2007-02-11 16:56:57.000000000 +0000
+@@ -52,6 +52,8 @@
+ #include <qtimer.h>
+ #include <qpopupmenu.h>
+ #include <qmessagebox.h>
++#include <qfile.h>
++#include <qtextstream.h>
+ /* STD */
+ #include <device.h>
+@@ -124,6 +126,28 @@
+     int BluezApplet::setBluezStatus(int c, bool sync) {
+         if ( c == 1 ) {
++
++          QFile cfg("/etc/sysconfig/bluetooth");
++          if(cfg.open(IO_ReadOnly)) {
++              QTextStream stream (&cfg);
++              QString streamIn = stream.read();
++              QStringList list = QStringList::split("\n", streamIn);
++              cfg.close();
++              if(list.grep("BLUETOOTH_PORT=").count() > 0 &&
++                   list.grep("BLUETOOTH_PROTOCOL=").count() > 0 &&
++                   list.grep("BLUETOOTH_SPEED=").count() > 0) {
++                  btDevice = new Device( list.grep("BLUETOOTH_PORT=")[0].
++                                           replace((QString)"BLUETOOTH_PORT=", ""),
++                                           list.grep("BLUETOOTH_PROTOCOL=")[0].
++                                           replace((QString)"BLUETOOTH_PROTOCOL=", ""),
++                                           list.grep("BLUETOOTH_SPEED=")[0].
++                                           replace((QString)"BLUETOOTH_SPEED=", ""));
++                    return 0;
++              }
++          }
++
++          // Device-specific stuff - should be removed
++
+             switch ( ODevice::inst()->model() ) {
+             case Model_iPAQ_H39xx:
+                 btDevice = new Device( "/dev/tts/1", "bcsp", "921600" );
index bf9cc56..a919c30 100644 (file)
@@ -1,6 +1,8 @@
 require ${PN}.inc
 
 PV = "${OPIE_CVS_PV}"
+PR = "r1"
 
 SRC_URI = "${HANDHELDS_CVS};module=opie/noncore/net/opietooth/applet \
-           ${HANDHELDS_CVS};module=opie/pics/bluetoothapplet"
+           ${HANDHELDS_CVS};module=opie/pics/bluetoothapplet \
+           file://sysconfig-bluetooth.patch;patch=1"