freetype: update to version 2.3.6
authorHenning Heinold <heinold@inf.fu-berlin.de>
Wed, 11 Jun 2008 21:28:33 +0000 (21:28 +0000)
committerHenning Heinold <heinold@inf.fu-berlin.de>
Wed, 11 Jun 2008 21:28:33 +0000 (21:28 +0000)
* fixing security issuses with 2.3.5 and before
* patch fix-x86_64-build.patch seems to be applied upstream

packages/freetype/freetype-native_2.3.6.bb [new file with mode: 0644]
packages/freetype/freetype_2.3.6.bb [new file with mode: 0644]

diff --git a/packages/freetype/freetype-native_2.3.6.bb b/packages/freetype/freetype-native_2.3.6.bb
new file mode 100644 (file)
index 0000000..b5e8b30
--- /dev/null
@@ -0,0 +1,21 @@
+require freetype_${PV}.bb
+inherit native
+DEPENDS = ""
+FILESPATH = "${FILE_DIRNAME}/freetype-${PV}:${FILE_DIRNAME}/freetype:${FILE_DIRNAME}/files"
+
+EXTRA_OEMAKE=
+
+do_configure() {
+       (cd builds/unix && gnu-configize) || die "failure running gnu-configize"
+       oe_runconf
+}
+
+do_stage() {
+       autotools_stage_includes
+       oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
+}
+
+do_install() {
+       :
+}
+
diff --git a/packages/freetype/freetype_2.3.6.bb b/packages/freetype/freetype_2.3.6.bb
new file mode 100644 (file)
index 0000000..1333997
--- /dev/null
@@ -0,0 +1,39 @@
+DESCRIPTION = "Freetype font rendering library"
+SECTION = "libs"
+LICENSE = "freetype"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
+           file://no-hardcode.patch;patch=1 \
+         "
+
+S = "${WORKDIR}/freetype-${PV}"
+
+inherit autotools pkgconfig binconfig
+
+LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
+EXTRA_OECONF = "--without-zlib"
+
+do_configure() {
+       cd builds/unix
+       libtoolize --force --copy
+       gnu-configize --force
+       aclocal -I .
+       autoconf
+       cd ${S}
+       oe_runconf
+}
+
+do_compile_prepend() {
+       ${BUILD_CC} -o objs/apinames src/tools/apinames.c
+}
+
+do_stage() {
+     export LIBTOOL='${LIBTOOL}'
+        autotools_stage_all
+        oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
+}
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}"