python-imaging: update to version 1.1.6 and split out .debug and docs into separate...
authoracid-burn <acidburn@opendreambox.org>
Tue, 1 Sep 2009 13:30:08 +0000 (15:30 +0200)
committeracid-burn <acidburn@opendreambox.org>
Tue, 1 Sep 2009 13:30:08 +0000 (15:30 +0200)
packages/python/python-imaging_1.1.5.bb [deleted file]
packages/python/python-imaging_1.1.6.bb [new file with mode: 0755]

diff --git a/packages/python/python-imaging_1.1.5.bb b/packages/python/python-imaging_1.1.5.bb
deleted file mode 100644 (file)
index ae00249..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-DESCRIPTION = "Python Imaging Library"
-SECTION = "devel/python"
-PRIORITY = "optional"
-LICENSE = "GPL"
-DEPENDS = "freetype jpeg"
-RDEPENDS = "python-lang python-stringold"
-SRCNAME = "Imaging"
-
-PR = "r1"
-
-SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
-file://path.patch;patch=1"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit distutils
-
-do_compile() {
-
-    export STAGING_LIBDIR=${STAGING_LIBDIR}
-    export STAGING_INCDIR=${STAGING_INCDIR}
-    distutils_do_compile
-}
-
-do_install() {
-
-    export STAGING_LIBDIR=${STAGING_LIBDIR}
-    export STAGING_INCDIR=${STAGING_INCDIR}
-    
-    distutils_do_install
-
-    install -d ${D}${datadir}/doc/${PN}/html/
-    install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/
-    install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/
-
-}
diff --git a/packages/python/python-imaging_1.1.6.bb b/packages/python/python-imaging_1.1.6.bb
new file mode 100755 (executable)
index 0000000..7c8c733
--- /dev/null
@@ -0,0 +1,47 @@
+DESCRIPTION = "Python Imaging Library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "freetype jpeg tiff"
+RDEPENDS = "python-lang python-stringold"
+RDEPENDS_${PN}-doc = "${PN}"
+SRCNAME = "Imaging"
+PR = "ml2"
+
+SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
+           file://path.patch;patch=1"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+# Exclude debug files from the main packages
+FILES_${PN} = " \
+       ${bindir}/* \
+       ${libdir}/${PYTHON_DIR}/site-packages/PIL.pth \
+       ${libdir}/${PYTHON_DIR}/site-packages/PIL/*egg-info \
+       ${libdir}/${PYTHON_DIR}/site-packages/PIL/*.py* \
+       ${libdir}/${PYTHON_DIR}/site-packages/PIL/*.so \
+"
+
+FILES_${PN}-dbg += " \
+       ${libdir}/${PYTHON_DIR}/site-packages/PIL/.debug \
+"
+
+FILES_${PN}-doc += " \
+       ${docdir}/* \
+"
+
+do_compile() {
+       export STAGING_LIBDIR=${STAGING_LIBDIR}
+  export STAGING_INCDIR=${STAGING_INCDIR}
+  distutils_do_compile
+}
+
+do_install() {
+  export STAGING_LIBDIR=${STAGING_LIBDIR}
+  export STAGING_INCDIR=${STAGING_INCDIR}
+  distutils_do_install
+  install -d ${D}${datadir}/doc/${PN}/html/
+  install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/
+  install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/
+}