pax-utils: fixed 404 not found
authorDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>
Thu, 12 Feb 2009 14:37:20 +0000 (15:37 +0100)
committerDenis 'Gnutoo' Carikli <GNUtoo@no-log.org>
Thu, 12 Feb 2009 14:40:38 +0000 (15:40 +0100)
*while downloading pax-utils I had:
NOTE: fetch http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/pax-utils-0.1.13.tar.bz2
--2009-02-12 13:06:15--  http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/pax-utils-0.1.13.tar.bz2
Resolving distro.ibiblio.org... 152.46.7.109
Connecting to distro.ibiblio.org|152.46.7.109|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2009-02-12 13:06:16 ERROR 404: Not Found.
NOTE: Task failed: Fetch failed: http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/pax-utils-0.1.13.tar.bz2;md5sum=5f09df47a16e83462384b44b75310539
NOTE: package pax-utils-native-0.1.13-r0: task do_fetch: failed

so I replaced the url(and removed the useless md5sum,i commited the checksum in the previous commit)
What I checked:
*the md5sum that will be commited in the checksums is the same than the one in the URI
*solar is a gentoo-hardened develloper and the PaX lead develloper:
**http://www.gentoo.org/proj/en/devrel/roll-call/userinfo.xml
**http://www.gentoo.org/proj/en/hardened/index.xml

packages/pax-utils/pax-utils_0.1.13.bb

index 6fc6850..9a35084 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Various ELF utilities"
 HOMEPAGE    = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
 LICENSE     = "GPLv2"
 
-SRC_URI     = "${GENTOO_MIRROR}/pax-utils-${PV}.tar.bz2;md5sum=5f09df47a16e83462384b44b75310539"
+SRC_URI     = "http://dev.gentoo.org/~solar/pax/pax-utils-${PV}.tar.bz2"
 S           = "${WORKDIR}/pax-utils-${PV}"
 
 CPPFLAGS   += "-D_GNU_SOURCE "