pcmciautils: Update patch to fix install breakage.
authorFlorian Boor <florian.boor@kernelconcepts.de>
Fri, 25 May 2007 17:44:46 +0000 (17:44 +0000)
committerFlorian Boor <florian.boor@kernelconcepts.de>
Fri, 25 May 2007 17:44:46 +0000 (17:44 +0000)
packages/pcmciautils/pcmciautils-014/makefile_fix.patch

index fed5d37..f5bb64b 100644 (file)
@@ -13,3 +13,76 @@ Index: pcmciautils-014/Makefile
  INSTALL_PROGRAM = ${INSTALL}
  INSTALL_DATA  = ${INSTALL} -m 644
  INSTALL_SCRIPT = ${INSTALL_PROGRAM}
+--- pcmciautils-014/Makefile~  2007-05-25 19:40:39.000000000 +0200
++++ pcmciautils-014/Makefile   2007-05-25 19:40:39.000000000 +0200
+@@ -258,28 +258,29 @@
+ install-hotplug:
+       $(INSTALL) -d $(DESTDIR)$(hotplugdir)
+-      $(INSTALL_PROGRAM) -D hotplug/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.agent
+-      $(INSTALL_PROGRAM) -D hotplug/pcmcia.rc $(DESTDIR)$(hotplugdir)/pcmcia.rc
++      $(INSTALL_PROGRAM) hotplug/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.agent
++      $(INSTALL_PROGRAM) hotplug/pcmcia.rc $(DESTDIR)$(hotplugdir)/pcmcia.rc
+ uninstall-hotplug:
+       - rm -f $(DESTDIR)$(hotplugdir)/pcmcia.agent $(DESTDIR)$(hotplugdir)/pcmcia.rc
+ install-socket-hotplug:
+-      $(INSTALL_PROGRAM) -D hotplug/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent
+-      $(INSTALL_PROGRAM) -D hotplug/pcmcia_socket.rc $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
++      $(INSTALL_PROGRAM) hotplug/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent
++      $(INSTALL_PROGRAM)  hotplug/pcmcia_socket.rc $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
+ uninstall-socket-hotplug:
+       - rm -f $(DESTDIR)$(hotplugdir)/pcmcia_socket.agent $(DESTDIR)$(hotplugdir)/pcmcia_socket.rc
+ install-socket-tools:
+-      $(INSTALL_PROGRAM) -D $(PCMCIA_SOCKET_STARTUP) $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
++      $(INSTALL) -d $(DESTDIR)$(sbindir)
++      $(INSTALL_PROGRAM) $(PCMCIA_SOCKET_STARTUP) $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
+ uninstall-socket-tools:
+       - rm -f $(DESTDIR)$(sbindir)/$(PCMCIA_SOCKET_STARTUP)
+ install-tools:
+       $(INSTALL) -d $(DESTDIR)$(sbindir)
+-      $(INSTALL_PROGRAM) -D $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(PCCARDCTL)
+-      $(INSTALL_PROGRAM) -D $(PCMCIA_CHECK_BROKEN_CIS) $(DESTDIR)$(sbindir)/$(PCMCIA_CHECK_BROKEN_CIS)
++      $(INSTALL_PROGRAM) $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(PCCARDCTL)
++      $(INSTALL_PROGRAM) $(PCMCIA_CHECK_BROKEN_CIS) $(DESTDIR)$(sbindir)/$(PCMCIA_CHECK_BROKEN_CIS)
+       $(SYMLINK) $(PCCARDCTL) $(DESTDIR)$(sbindir)/$(LSPCMCIA)
+ uninstall-tools:
+@@ -289,18 +290,20 @@
+ install-config:
+       $(INSTALL) -d $(DESTDIR)$(pcmciaconfdir)
+-      $(INSTALL_DATA)  -D config/config.opts $(DESTDIR)$(pcmciaconfdir)/config.opts
++      $(INSTALL_DATA)  config/config.opts $(DESTDIR)$(pcmciaconfdir)/config.opts
+ uninstall-config:
+ #     - rm -f $(DESTDIR)$(pcmciaconfdir)/config.opts
+ install-udev:
+-      $(INSTALL_DATA) -D $(UDEV_RULES_FILE) $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
++      $(INSTALL) -d  $(DESTDIR)$(udevrulesdir)
++      $(INSTALL_DATA) $(UDEV_RULES_FILE) $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
+ uninstall-udev:
+       - rm -f $(DESTDIR)$(udevrulesdir)/60-pcmcia.rules
+ install-man:
++      $(INSTALL) -d $(DESTDIR)$(mandir)/man8
+       $(INSTALL_DATA) -D man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
+       $(SYMLINK) pccardctl.8 $(DESTDIR)$(mandir)/man8/lspcmcia.8
+--- pcmciautils-014/Makefile~  2007-05-25 19:43:01.000000000 +0200
++++ pcmciautils-014/Makefile   2007-05-25 19:43:01.000000000 +0200
+@@ -304,7 +304,7 @@
+ install-man:
+       $(INSTALL) -d $(DESTDIR)$(mandir)/man8
+-      $(INSTALL_DATA) -D man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
++      $(INSTALL_DATA) man/man8/pccardctl.8 $(DESTDIR)$(mandir)/man8/pccardctl.8
+       $(SYMLINK) pccardctl.8 $(DESTDIR)$(mandir)/man8/lspcmcia.8
+ uninstall-man: