cherokee: release 0.4.29
authorJohn Bowler <jbowler@nslu2-linux.org>
Tue, 22 Nov 2005 19:41:01 +0000 (19:41 +0000)
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>
Tue, 22 Nov 2005 19:41:01 +0000 (19:41 +0000)
  - this release works with patches to classes/base.bbclass oe_libinstall
  - to install libpcre.la in staging with 'installed=no', otherwise the
  - package will fail to compile.  The commit does not include the bbclass
  - fixes (they require more testing) - to use it hand hack libpcre.la in
  - the staging directory.

packages/cherokee/.mtn2git_empty [new file with mode: 0644]
packages/cherokee/cherokee_0.4.29.bb [new file with mode: 0644]
packages/cherokee/files/.mtn2git_empty [new file with mode: 0644]
packages/cherokee/files/Makefile.cget.patch [new file with mode: 0644]
packages/cherokee/files/Makefile.in.patch [new file with mode: 0644]
packages/cherokee/files/configure.patch [new file with mode: 0644]
packages/cherokee/files/util.patch [new file with mode: 0644]

diff --git a/packages/cherokee/.mtn2git_empty b/packages/cherokee/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/cherokee/cherokee_0.4.29.bb b/packages/cherokee/cherokee_0.4.29.bb
new file mode 100644 (file)
index 0000000..0d2eb3d
--- /dev/null
@@ -0,0 +1,24 @@
+# Cherokee web server
+DESCRIPTION = "Cherokee Web Server fast and secure"
+LICENSE = "GPL"
+DEPENDS = "openssl pcre"
+SRC_URI = "http://www.0x50.org/download/0.4/${PV}/${P}.tar.gz \
+         file://configure.patch;patch=1 \
+         file://Makefile.in.patch;patch=1 \
+         file://Makefile.cget.patch;patch=1 \
+         file://util.patch;patch=1"
+
+inherit autotools
+
+LEAD_SONAME = "libcherokee-base"
+
+EXTRA_OECONF = "--enable-tls=openssl --disable-static --disable-nls"
+
+do_configure() {
+       gnu-configize
+       oe_runconf
+}
+
+do_install_prepend () {
+       $BUILD_CC -DHAVE_SYS_STAT_H -o cherokee_replace cherokee_replace.c
+}
diff --git a/packages/cherokee/files/.mtn2git_empty b/packages/cherokee/files/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/cherokee/files/Makefile.cget.patch b/packages/cherokee/files/Makefile.cget.patch
new file mode 100644 (file)
index 0000000..bb6b214
--- /dev/null
@@ -0,0 +1,23 @@
+
+#
+# Patch managed by http://www.xwaves.net
+#
+
+--- cherokee-0.4.29/cget/Makefile.in~Makefile.cget
++++ cherokee-0.4.29/cget/Makefile.in
+@@ -56,6 +56,7 @@
+ cget_OBJECTS = $(am_cget_OBJECTS)
+ am__DEPENDENCIES_1 =
+ cget_DEPENDENCIES = ../cherokee/libcherokee-client.la \
++      ../cherokee/libcherokee-base.la \
+       $(am__DEPENDENCIES_1) $(am__DEPENDENCIES_1) \
+       $(am__DEPENDENCIES_1)
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
+@@ -286,6 +287,7 @@
+ cget_LDADD = \
+ ../cherokee/libcherokee-client.la \
++../cherokee/libcherokee-base.la \
+ $(TLS_LIBS) \
+ $(PTHREAD_LIBS) \
+ $(PTHREAD_CFLAGS)
diff --git a/packages/cherokee/files/Makefile.in.patch b/packages/cherokee/files/Makefile.in.patch
new file mode 100644 (file)
index 0000000..9d27812
--- /dev/null
@@ -0,0 +1,33 @@
+
+#
+# Patch managed by http://www.xwaves.net
+#
+
+--- cherokee-0.4.29/cherokee/Makefile.in~Makefile
++++ cherokee-0.4.29/cherokee/Makefile.in
+@@ -403,11 +403,11 @@
+ am_cherokee_admin_OBJECTS = cherokee_admin.$(OBJEXT)
+ cherokee_admin_OBJECTS = $(am_cherokee_admin_OBJECTS)
+ cherokee_admin_DEPENDENCIES = libcherokee-config.la \
+-      libcherokee-base.la libcherokee-client.la
++      libcherokee-base.la libcherokee-client.la libcherokee-server.la
+ am_cherokee_logrotate_OBJECTS = cherokee_logrotate.$(OBJEXT)
+ cherokee_logrotate_OBJECTS = $(am_cherokee_logrotate_OBJECTS)
+ cherokee_logrotate_DEPENDENCIES = libcherokee-config.la \
+-      libcherokee-base.la libcherokee-client.la
++      libcherokee-base.la libcherokee-client.la libcherokee-server.la
+ binSCRIPT_INSTALL = $(INSTALL_SCRIPT)
+ SCRIPTS = $(bin_SCRIPTS)
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
+@@ -1343,9 +1343,9 @@
+ cherokee_LDFLAGS = -export-dynamic
+ cherokee_logrotate_SOURCES = cherokee_logrotate.c
+-cherokee_logrotate_LDADD = libcherokee-config.la libcherokee-base.la libcherokee-client.la 
++cherokee_logrotate_LDADD = libcherokee-config.la libcherokee-base.la libcherokee-client.la libcherokee-server.la
+ cherokee_admin_SOURCES = cherokee_admin.c 
+-cherokee_admin_LDADD = libcherokee-config.la libcherokee-base.la libcherokee-client.la 
++cherokee_admin_LDADD = libcherokee-config.la libcherokee-base.la libcherokee-client.la libcherokee-server.la
+ #noinst_PROGRAMS = cherokee_modules cherokee_base64 cherokee_headers cherokee_fastcgi
diff --git a/packages/cherokee/files/configure.patch b/packages/cherokee/files/configure.patch
new file mode 100644 (file)
index 0000000..9c34d96
--- /dev/null
@@ -0,0 +1,127 @@
+
+#
+# Patch managed by http://www.xwaves.net
+#
+
+--- cherokee-0.4.29/configure~configure
++++ cherokee-0.4.29/configure
+@@ -28929,59 +28929,8 @@
+ if test "x$have_epoll_include" = "xyes"; then
+       echo "$as_me:$LINENO: checking for epoll system call" >&5
+ echo $ECHO_N "checking for epoll system call... $ECHO_C" >&6
+-
+-     if test "$cross_compiling" = yes; then
+-  { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: cannot run test program while cross compiling
+-See \`config.log' for more details." >&2;}
+-   { (exit 1); exit 1; }; }
+-else
+-  cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h.  */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h.  */
+-
+-              #include <stdint.h>
+-              #include <sys/param.h>
+-              #include <sys/types.h>
+-              #include <sys/syscall.h>
+-              #include <sys/epoll.h>
+-              #include <unistd.h>
+-
+-              int epoll_create (int size) {
+-              return (syscall(__NR_epoll_create, size));
+-              }
+-
+-              int main (int argc, char **argv) {
+-              int epfd;
+-              epfd = epoll_create(256);
+-                 exit (epfd == -1 ? 1 : 0);
+-              }
+-
+-_ACEOF
+-rm -f conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+-  (eval $ac_link) 2>&5
+-  ac_status=$?
+-  echo "$as_me:$LINENO: \$? = $ac_status" >&5
+-  (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
+-  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+-  (eval $ac_try) 2>&5
+-  ac_status=$?
+-  echo "$as_me:$LINENO: \$? = $ac_status" >&5
+-  (exit $ac_status); }; }; then
+-  have_epoll=yes
+-else
+-  echo "$as_me: program exited with status $ac_status" >&5
+-echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-
+-fi
+-rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
+-fi
++have_epoll=yes
++   
+       echo "$as_me:$LINENO: result: $have_epoll" >&5
+ echo "${ECHO_T}$have_epoll" >&6
+ fi
+@@ -32593,55 +32542,9 @@
+ # Is sendfile broken?
+ echo "$as_me:$LINENO: checking if sendfile works" >&5
+ echo $ECHO_N "checking if sendfile works... $ECHO_C" >&6
+-if test "$cross_compiling" = yes; then
+-  { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
+-See \`config.log' for more details." >&5
+-echo "$as_me: error: cannot run test program while cross compiling
+-See \`config.log' for more details." >&2;}
+-   { (exit 1); exit 1; }; }
+-else
+-  cat >conftest.$ac_ext <<_ACEOF
+-/* confdefs.h.  */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h.  */
+-#include <errno.h>
+-            int main() {
+-               int o = 0;
+-               if (-1 == sendfile(0, 0, &o, 0) && errno == ENOSYS) return -1;
+-               return 0;
+-            }
+-_ACEOF
+-rm -f conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+-  (eval $ac_link) 2>&5
+-  ac_status=$?
+-  echo "$as_me:$LINENO: \$? = $ac_status" >&5
+-  (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
+-  { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+-  (eval $ac_try) 2>&5
+-  ac_status=$?
+-  echo "$as_me:$LINENO: \$? = $ac_status" >&5
+-  (exit $ac_status); }; }; then
+-  echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6
+-else
+-  echo "$as_me: program exited with status $ac_status" >&5
+-echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
+-( exit $ac_status )
+- echo "$as_me:$LINENO: result: no" >&5
+-echo "${ECHO_T}no" >&6
+-
+-cat >>confdefs.h <<\_ACEOF
+-#define HAVE_SENDFILE_BROKEN 1
+-_ACEOF
+-
+-fi
+-rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
+-fi
++echo "$as_me:$LINENO: result: yes" >&5
++echo "${ECHO_T}yes" >&6
+ # readdir_r()
diff --git a/packages/cherokee/files/util.patch b/packages/cherokee/files/util.patch
new file mode 100644 (file)
index 0000000..5319f18
--- /dev/null
@@ -0,0 +1,19 @@
+
+#
+# Patch managed by http://www.xwaves.net
+#
+
+--- cherokee-0.4.29/cherokee/util.c~util
++++ cherokee-0.4.29/cherokee/util.c
+@@ -348,9 +348,9 @@
+-#if defined(HAVE_PTHREAD) && !defined(HAVE_READDIR_R)
++/*#if defined(HAVE_PTHREAD) && !defined(HAVE_READDIR_R)*/
+ static pthread_mutex_t readdir_mutex = PTHREAD_MUTEX_INITIALIZER;
+-#endif
++/*#endif*/
+ /* The readdir subroutine is reentrant when an application program
+  * uses different DirectoryPointer parameter values (returned from the