chillispot: patch to fix compilation errors
authorMartin Dietze <di@fh-wedel.de>
Fri, 8 Sep 2006 13:06:05 +0000 (13:06 +0000)
committerMartin Dietze <di@fh-wedel.de>
Fri, 8 Sep 2006 13:06:05 +0000 (13:06 +0000)
* remove the -ansi switch from the CFLAGS since some files are unix-style sources and do not compile in ansi mode

packages/chillispot/chillispot-0.98/.mtn2git_empty [new file with mode: 0644]
packages/chillispot/chillispot-0.98/no-ansi.patch [new file with mode: 0644]
packages/chillispot/chillispot-1.0RC3/.mtn2git_empty [new file with mode: 0644]
packages/chillispot/chillispot-1.0RC3/no-ansi.patch [new file with mode: 0644]

diff --git a/packages/chillispot/chillispot-0.98/.mtn2git_empty b/packages/chillispot/chillispot-0.98/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/chillispot/chillispot-0.98/no-ansi.patch b/packages/chillispot/chillispot-0.98/no-ansi.patch
new file mode 100644 (file)
index 0000000..3a58433
--- /dev/null
@@ -0,0 +1,10 @@
+--- chillispot-0.98/src/Makefile.am.org        2006-02-01 11:04:39.086469680 +0100
++++ chillispot-0.98/src/Makefile.am    2006-02-01 11:04:46.451350048 +0100
+@@ -1,6 +1,6 @@
+ sbin_PROGRAMS = chilli
+-AM_CFLAGS = -D_GNU_SOURCE -fno-builtin -ansi -DSBINDIR='"$(sbindir)"' 
++AM_CFLAGS = -D_GNU_SOURCE -fno-builtin -DSBINDIR='"$(sbindir)"' 
+ chilli_SOURCES = chilli.c defs.h tun.c tun.h cmdline.c cmdline.h ippool.c ippool.h radius.h radius.c md5.c md5.h redir.h redir.c dhcp.c dhcp.h syserr.c syserr.h iphash.c iphash.h
diff --git a/packages/chillispot/chillispot-1.0RC3/.mtn2git_empty b/packages/chillispot/chillispot-1.0RC3/.mtn2git_empty
new file mode 100644 (file)
index 0000000..e69de29
diff --git a/packages/chillispot/chillispot-1.0RC3/no-ansi.patch b/packages/chillispot/chillispot-1.0RC3/no-ansi.patch
new file mode 100644 (file)
index 0000000..3a3ffab
--- /dev/null
@@ -0,0 +1,11 @@
+--- chillispot-1.0RC3/src/Makefile.am.org      2006-02-01 10:43:45.628024328 +0100
++++ chillispot-1.0RC3/src/Makefile.am  2006-02-01 10:43:50.922219488 +0100
+@@ -1,7 +1,7 @@
+ sbin_PROGRAMS = chilli
+ # add -pg to enable gprof
+-AM_CFLAGS = -D_GNU_SOURCE -fno-builtin -ansi -DSBINDIR='"$(sbindir)"' 
++AM_CFLAGS = -D_GNU_SOURCE -fno-builtin -DSBINDIR='"$(sbindir)"' 
+ chilli_SOURCES = chilli.c defs.h tun.c tun.h cmdline.c cmdline.h ippool.c ippool.h radius.h radius.c md5.c md5.h redir.h redir.c dhcp.c dhcp.h syserr.c syserr.h iphash.c iphash.h lookup.c lookup.h