enigma2: workaround buggy extra_depends on split_packages
authorFelix Domke <felix.domke@multimedia-labs.de>
Tue, 18 Aug 2009 18:25:40 +0000 (20:25 +0200)
committerFelix Domke <felix.domke@multimedia-labs.de>
Tue, 18 Aug 2009 18:25:40 +0000 (20:25 +0200)
packages/enigma2/enigma2.bb

index 1b469e4..60af4ff 100755 (executable)
@@ -51,7 +51,7 @@ RDEPENDS_enigma2-plugin-extensions-modem = "dreambox-modem-ppp-scripts"
 
 PN = "enigma2"
 PR = "r0"
 
 PN = "enigma2"
 PR = "r0"
-SRCDATE = "20090817"
+SRCDATE = "20090819"
 
 # if you want experimental, use:
 REL_MAJOR="2"
 
 # if you want experimental, use:
 REL_MAJOR="2"
@@ -89,7 +89,7 @@ do_install_append() {
 python populate_packages_prepend () {
        enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
 
 python populate_packages_prepend () {
        enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
 
-       do_split_packages(d, enigma2_plugindir, '(.*?/.*?)/.*', 'enigma2-plugin-%s', '%s ', recursive=True, match_path=True, prepend=True)
+       do_split_packages(d, enigma2_plugindir, '(.*?/.*?)/.*', 'enigma2-plugin-%s', '%s ', recursive=True, match_path=True, prepend=True, extra_depends="enigma2")
 }
 
 do_stage_append() {
 }
 
 do_stage_append() {