749fa1e97514f1a429203ad9c30288329381f5b1
[vuplus_openembedded] / recipes / opkg / opkg_svn.bb
1 require opkg.inc
2
3 PR = "r12"
4
5 PACKAGES =+ "libopkg-dev libopkg"
6
7 FILES_libopkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
8 FILES_libopkg = "${libdir}/*.so.*"
9
10 # Define a variable to allow distros to run configure earlier.
11 # (for example, to enable loading of ethernet kernel modules before networking starts)
12 OPKG_INIT_POSITION = "98"
13 OPKG_INIT_POSITION_slugos = "41"
14
15 pkg_postinst_${PN} () {
16   update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
17 }
18
19 pkg_postrm_${PN} () {
20   update-alternatives --remove opkg ${bindir}/opkg-cl
21 }