6ada7acda48398d1cc5fdde2afba7558467596b9
[vuplus_openembedded] / recipes / enigma2 / enigma2.bb
1 DESCRIPTION = "Enigma2 is an experimental, but useful framebuffer-based frontend for DVB functions"
2 MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
3 DEPENDS = "jpeg libungif libmad libpng libsigc++-1.2 gettext-native \
4         dreambox-dvbincludes freetype libdvbsi++ python swig-native \
5         libfribidi libxmlccwrap libdreamdvd gstreamer gst-plugin-dvbmediasink \
6         gst-plugins-bad gst-plugins-good gst-plugins-ugly python-wifi wvdial wvstreams ppp usbmodeswitch usbmodeswitch-data \
7         hostap-daemon bridge-utils"
8 RDEPENDS = "python-codecs python-core python-lang python-re python-threading \
9         python-xml python-fcntl gst-plugin-decodebin gst-plugin-decodebin2 python-stringold \
10         python-pickle gst-plugin-app gst-plugin-fragmented \
11         gst-plugin-id3demux gst-plugin-mad gst-plugin-ogg gst-plugin-playbin \
12         gst-plugin-typefindfunctions gst-plugin-audioconvert gst-plugin-audioresample \
13         gst-plugin-wavparse python-netclient gst-plugin-mpegstream \
14         gst-plugin-flac gst-plugin-dvbmediasink gst-plugin-mpegdemux gst-plugin-dvdsub \
15         gst-plugin-souphttpsrc gst-plugin-mpegaudioparse gst-plugin-subparse \
16         gst-plugin-apetag gst-plugin-icydemux gst-plugin-autodetect gst-plugin-flv \
17         glibc-gconv-iso8859-15 ethtool"
18
19 GST_RTSP_RDEPENDS = "gst-plugin-udp gst-plugin-rtsp gst-plugin-rtp gst-plugin-rtpmanager"
20 GST_ALSA_RDEPENDS = "gst-plugin-alsa alsa-conf"
21 GST_MISC_RDEPENDS = "gst-plugin-matroska gst-plugin-isomp4 gst-plugin-vorbis gst-plugin-audioparsers"
22 GST_DVD_RDEPENDS = "gst-plugin-cdxaparse gst-plugin-cdio gst-plugin-vcdsrc"
23 GST_BASE_RDEPENDS = "${GST_ALSA_RDEPENDS} ${GST_MISC_RDEPENDS} ${GST_RTSP_RDEPENDS}"
24
25 RDEPENDS_append_dm7025 = " ${GST_ALSA_RDEPENDS} gst-plugin-ivorbisdec"
26 RDEPENDS_append_dm800 = " ${GST_BASE_RDEPENDS} gst-plugin-ivorbisdec"
27 RDEPENDS_append_dm8000 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
28 RDEPENDS_append_dm500hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
29 RDEPENDS_append_dm800se = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
30 RDEPENDS_append_bm750 = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
31 RDEPENDS_append_vusolo = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
32 RDEPENDS_append_vuuno = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
33 RDEPENDS_append_vuultimo = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
34 RDEPENDS_append_dm7020hd = " ${GST_BASE_RDEPENDS} ${GST_DVD_RDEPENDS} gst-plugin-avi"
35
36 # 'forward depends' - no two providers can have the same PACKAGES_DYNAMIC, however both
37 # enigma2 and enigma2-plugins produce enigma2-plugin-*.
38 #DEPENDS += "enigma2-plugins"
39 #PACKAGES_DYNAMIC = "enigma2-plugin-*"
40
41 DESCRIPTION_append_enigma2-plugin-extensions-cutlisteditor = "enables you to cut your movies."
42 RDEPENDS_enigma2-plugin-extensions-cutlisteditor = "aio-grab"
43 DESCRIPTION_append_enigma2-plugin-extensions-graphmultiepg = "shows a graphical timeline EPG."
44 DESCRIPTION_append_enigma2-plugin-extensions-pictureplayer = "displays photos on the TV."
45 DESCRIPTION_append_enigma2-plugin-systemplugins-frontprocessorupdate = "keeps your frontprocessor up to date."
46 DESCRIPTION_append_enigma2-plugin-systemplugins-positionersetup = "helps you installing a motorized dish."
47 DESCRIPTION_append_enigma2-plugin-systemplugins-satelliteequipmentcontrol = "allows you to fine-tune DiSEqC-settings."
48 DESCRIPTION_append_enigma2-plugin-systemplugins-satfinder = "helps you to align your dish."
49 DESCRIPTION_append_enigma2-plugin-systemplugins-skinselector = "shows a menu with selectable skins."
50 DESCRIPTION_append_enigma2-plugin-systemplugins-videomode = "selects advanced video modes"
51 RDEPENDS_enigma2-plugin-extensions-dvdplayer = "libdreamdvd0"
52 RDEPENDS_enigma2-plugin-systemplugins-nfiflash = "twisted-web"
53 RDEPENDS_enigma2-plugin-systemplugins-softwaremanager = "twisted-web"
54 RCONFLICTS_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
55 RREPLACES_enigma2-plugin-systemplugins-softwaremanager = "enigma2-plugin-systemplugins-configurationbackup enigma2-plugin-systemplugins-softwareupdate"
56 DESCRIPTION_append_enigma2-plugin-systemplugins-crashlogautosubmit = "automatically send crashlogs to Dream Multimedia"
57 RDEPENDS_enigma2-plugin-systemplugins-crashlogautosubmit = "twisted-mail twisted-names python-compression python-mime python-email"
58 DESCRIPTION_append_enigma2-plugin-systemplugins-cleanupwizard = "informs you on low internal memory on system startup."
59 DESCRIPTION_append_enigma2-plugin-extenstions-modem = "opens a menu to connect to internet via builtin modem."
60 RDEPENDS_enigma2-plugin-extensions-modem = "dreambox-modem-ppp-scripts ppp"
61 DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslan = "helps you configuring your wireless lan"
62 RDEPENDS_enigma2-plugin-systemplugins-wirelesslan = "wpa-supplicant wireless-tools python-wifi"
63 DESCRIPTION_append_enigma2-plugin-systemplugins-wirelesslansetup = "configure wireless lan"
64 RDEPENDS_enigma2-plugin-systemplugins-wirelesslansetup = "wpa-supplicant wireless-tools python-wifi"
65 DESCRIPTION_append_enigma2-plugin-systemplugins-networkwizard = "provides easy step by step network configuration"
66 RDEPENDS_enigma2-plugin-extensions-webbrowser = "python-gdata libqtwebkite4 vuplus-webbrowser-utils qt4-embedded-fonts qt4-embedded-plugin-imageformat-gif qt4-embedded-plugin-imageformat-ico qt4-embedded-plugin-imageformat-jpeg qt4-embedded-plugin-imageformat-mng qt4-embedded-plugin-imageformat-svg qt4-embedded-plugin-imageformat-tiff qt4-embedded-plugin-iconengine-svgicon "
67 DESCRIPTION_append_enigma2-plugin-systemplugins-crashreport = "automatically send crashlogs to Vu+"
68 RDEPENDS_enigma2-plugin-systemplugins-crashreport = "twisted-mail twisted-names python-compression python-mime python-email"
69 RDEPENDS_enigma2-plugin-systemplugins-3gmodemmanager = "ppp usbmodeswitch usbmodeswitch-data wvdial wvstreams libwvutils4.6 libwvstreams-extras libuniconf4.6"
70 RDEPENDS_enigma2-plugin-systemplugins-wirelessaccesspoint = "hostap-daemon bridge-utils"
71 RDEPENDS_enigma2-plugin-extensions-streamtv = "librtmp0 gst-plugin-rtmp "
72
73 PN = "enigma2"
74 PR = "r30"
75
76 SRCDATE = "20110922"
77 SRCREV = "5e19a3f8a5e8ce8a4e2cb2b601a1b8ef3554e4be"
78 #SRCDATE is NOT used by git to checkout a specific revision
79 #but we need it to build a ipk package version
80 #when you like to checkout a specific revision of e2 you need
81 #have to specify a commit id or a tag name in SRCREV
82
83 # if you want experimental use
84 ####################################################
85 BRANCH = "experimental"
86 PV = "experimental-git${SRCDATE}"
87 #SRCREV = ""
88 ####################################################
89
90 # if you want a 2.7-based release, use
91 ####################################################
92 #BRANCH="2.7"
93 #PV = "2.7git${SRCDATE}"
94 # if you want 2.7.0 use
95 #SRCREV = "d5a16c6e9d0ee1cc2dc0d65b4321842dea4b0891"
96 ####################################################
97
98 # if you want a vuplus release, use
99 ####################################################
100 #BRANCH_vuplus = "vuplus"
101 #PV_vuplus = "2.8git${SRCDATE}"
102 #SRCREV_vuplus = "4186f8c308d9450353520a88eb5a5ee3940281d3"
103 ####################################################
104
105 #if you want a vuplus experimental, use
106 ####################################################
107 BRANCH_vuplus = "vuplus_experimental"
108 PV_vuplus = "experimental-git${SRCDATE}"
109 SRCREV_vuplus = ""
110 ####################################################
111
112 #SRC_URI = "git://git.opendreambox.org/git/enigma2.git;protocol=git;branch=${BRANCH};tag=${SRCREV}"
113 #SRC_URI_append_dm7025 = " file://7025_pvr_device_compatibility.diff;patch=1;pnum=1"
114
115 # enigma2_vuplus_mediaplayer.patch is for trick-play in media player
116
117
118 SRC_URI = "git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=${BRANCH};tag=${SRCREV} \
119            file://enigma2_vuplus_skin.patch;patch=1;pnum=1 \
120            file://enigma2_vuplus_mediaplayer.patch;patch=1;pnum=1 \
121            file://enigma2_vuplus_mediaplayer_subtitle.patch;patch=1;pnum=1 \
122            file://enigma2_vuplus_remove_dreambox_enigma.patch;patch=1;pnum=1 \
123            file://enigma2_vuplus_vfd_mode.patch;patch=1;pnum=1 \
124            file://MyriadPro-Regular.otf \
125            file://MyriadPro-Semibold.otf \
126            file://MyriadPro-SemiboldIt.otf \
127            file://750S \
128            file://Vu_HD \
129            file://number_key \
130            "
131
132 SRC_URI_append_bm750 = " file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1"
133 SRC_URI_append_vuuno = " file://enigma2_vuplus_textvfd.patch;patch=1;pnum=1"
134
135 SRC_URI_append_vusolo = " file://enigma2_vuplus_misc.patch;patch=1;pnum=1"
136
137 SRC_URI_append = " ${@base_contains("MACHINE_FEATURES", "vuwlan", "file://enigma2_vuplus_networksetup.patch;patch=1;pnum=1", "", d)}"
138
139 SRC_URI_append_vuultimo = " \
140            file://analog.ttf \
141            file://skin_user.xml \
142            file://vfd_icons \
143 "
144
145 def change_po():
146         import os
147         try:
148                 os.system("find ./ -name \"*.po\" > ./po_list")
149                 os.system("find ./ -name \"*.pot\" >> ./po_list")
150                 po_list = []
151                 po_list = open('po_list','r+').readlines()
152                 for x in po_list:
153                         changeword(x)
154                 os.system('rm po_list')
155         except:
156                 print 'word patch error '
157                 return
158
159 def changeword(file):
160         fn = file[:-1]
161         fnn = file[:-1]+'_n'
162         cmd = "sed s/Dreambox/STB/g "+fn+" > "+fnn
163         os.system(cmd)
164         cmd1 = "mv "+fnn+" "+fn
165         os.system(cmd1)
166
167 do_unpack_append(){
168         change_po()
169 }
170
171 S = "${WORKDIR}/git"
172
173 FILES_${PN} += "${datadir}/fonts ${datadir}/keymaps"
174 FILES_${PN}-meta = "${datadir}/meta"
175 PACKAGES += "${PN}-meta"
176 PACKAGE_ARCH = "${MACHINE_ARCH}"
177
178 inherit autotools pkgconfig
179
180
181 do_compile_prepend_vuplus() {
182         install -m 0755 ${WORKDIR}/MyriadPro-Regular.otf ${S}/data/fonts/
183         install -m 0755 ${WORKDIR}/MyriadPro-Semibold.otf ${S}/data/fonts/
184         install -m 0755 ${WORKDIR}/MyriadPro-SemiboldIt.otf ${S}/data/fonts/
185         install -m 0755 ${WORKDIR}/750S/*.png ${S}/data/750S/
186         install -m 0755 ${WORKDIR}/750S/buttons/*.png ${S}/data/750S/buttons/
187         install -m 0755 ${WORKDIR}/750S/countries/*.png ${S}/data/750S/countries/
188         install -m 0755 ${WORKDIR}/750S/icons/*.png ${S}/data/750S/icons/
189         install -m 0755 ${WORKDIR}/750S/menu/*.png ${S}/data/750S/menu/
190         install -m 0755 ${WORKDIR}/750S/spinner/*.png ${S}/data/skin_default/spinner/
191         install -m 0755 ${WORKDIR}/Vu_HD/*.png ${S}/data/Vu_HD/
192         install -m 0755 ${WORKDIR}/Vu_HD/buttons/*.png ${S}/data/Vu_HD/buttons/
193         install -m 0755 ${WORKDIR}/Vu_HD/countries/*.png ${S}/data/Vu_HD/countries/
194         install -m 0755 ${WORKDIR}/Vu_HD/icons/*.png ${S}/data/Vu_HD/icons/
195         install -m 0755 ${WORKDIR}/Vu_HD/menu/*.png ${S}/data/Vu_HD/menu/
196         install -m 0755 ${WORKDIR}/number_key/*.png ${S}/data/skin_default/buttons/
197 }
198
199 EXTRA_OECONF = " \
200         ${@base_contains("MACHINE_FEATURES", "display-text-vfd", "--with-display-text-vfd" , "", d)} \
201         ${@base_contains("MACHINE_FEATURES", "display-graphic-vfd", "--with-display-graphic-vfd" , "", d)} \
202         ${@base_contains("MACHINE_FEATURES", "right-half-vfd-skin", "--with-set-right-half-vfd-skin" , "", d)} \
203         ${@base_contains("MACHINE_FEATURES", "enable-rc-kbd", "--with-remote-keyboard" , "", d)} \
204         BUILD_SYS=${BUILD_SYS} \
205         HOST_SYS=${HOST_SYS} \
206         STAGING_INCDIR=${STAGING_INCDIR} \
207         STAGING_LIBDIR=${STAGING_LIBDIR} \
208 "
209
210 do_install_append_vuultimo() {
211         install -m 0755 ${WORKDIR}/analog.ttf ${D}/usr/share/fonts/
212         install -m 0755 ${WORKDIR}/skin_user.xml ${D}/usr/share/enigma2/defaults/
213         install -d ${D}/usr/share/enigma2/vfd_icons/
214         install -m 0755 ${WORKDIR}/vfd_icons/*.png ${D}/usr/share/enigma2/vfd_icons/
215 }
216
217 python populate_packages_prepend () {
218         enigma2_plugindir = bb.data.expand('${libdir}/enigma2/python/Plugins', d)
219
220         do_split_packages(d, enigma2_plugindir, '(.*?/.*?)/.*', 'enigma2-plugin-%s', '%s ', recursive=True, match_path=True, prepend=True)
221 }
222
223 RCONFLICTS_${PN} = "dreambox-keymaps"
224 RREPLACES_${PN} = "dreambox-keymaps tuxbox-tuxtxt-32bpp (<= 0.0+cvs20090130-r1)"
225
226 # workaround for opkg <= 0.1.7+svnr455-r19.1
227 pkg_preinst_${PN} () {
228         if [ "x$D" != "x" ]; then
229                 exit 1
230         fi
231         if [ -f ${datadir}/fonts/tuxtxt.ttf ]; then
232                 cp -a ${datadir}/fonts/tuxtxt.ttf /tmp/tuxtxt.ttf
233         fi
234 }
235 pkg_postinst_${PN} () {
236         if [ "x$D" != "x" ]; then
237                 exit 1
238         fi
239         if [ -f /tmp/tuxtxt.ttf -a ! -f ${datadir}/fonts/tuxtxt.ttf ]; then
240                 mv /tmp/tuxtxt.ttf ${datadir}/fonts/tuxtxt.ttf
241         fi
242 }