e9c2509295016e74e17b86b7184ebcde8bc1da68
[vuplus_openembedded] / recipes / busybox / busybox_1.15.3.bb
1 require busybox.inc
2 PR = "${INC_PR}.9"
3
4 SRC_URI = "\
5   http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
6   \
7   file://udhcpscript.patch;patch=1 \
8   file://udhcpc-fix-nfsroot.patch;patch=1 \
9   file://B921600.patch;patch=1 \
10   file://get_header_tar.patch;patch=1 \
11   file://busybox-appletlib-dependency.patch;patch=1 \
12   file://find-touchscreen.sh \
13   file://busybox-cron \
14   file://busybox-httpd \
15   file://busybox-udhcpd \
16   file://default.script file://simple.script \
17   file://hwclock.sh \
18   file://mount.busybox \
19   file://mountall \
20   file://syslog \
21   file://syslog.conf \
22   file://umount.busybox \
23   file://defconfig \
24   file://mdev \
25   file://mdev.conf \
26   file://devfsd.conf \
27 "
28
29 SRC_URI_append_opendreambox = "\
30   file://dhcp-hostname.patch;patch=1 \
31   file://keymap_endianess.patch;patch=1 \
32   file://nptl_task.patch;patch=1 \
33 "
34 SRC_URI_append_vuplus = "\
35   file://dhcp-hostname.patch;patch=1 \
36   file://keymap_endianess.patch;patch=1 \
37   file://nptl_task.patch;patch=1 \
38 "
39
40 EXTRA_OEMAKE += "V=1 ARCH=${TARGET_ARCH} CROSS_COMPILE=${TARGET_PREFIX}"
41
42 do_configure_prepend () {
43         if [ "${TARGET_ARCH}" = "avr32" ] ; then
44                 sed -i s:CONFIG_FEATURE_OSF_LABEL=y:CONFIG_FEATURE_OSF_LABEL=n: ${WORKDIR}/defconfig
45         fi
46 }
47
48 do_install_append() {
49     install -m 0644 ${WORKDIR}/mdev.conf ${D}${sysconfdir}/
50     install -d ${D}${sysconfdir}/init.d/
51     install -d ${D}${sysconfdir}/mdev
52     install -m 0755 ${WORKDIR}/find-touchscreen.sh ${D}${sysconfdir}/mdev/
53     install -m 0755 ${WORKDIR}/mdev ${D}${sysconfdir}/init.d/
54     if grep "CONFIG_DEVFSD=y" ${WORKDIR}/defconfig; then
55         install -m 644 ${WORKDIR}/devfsd.conf ${D}${sysconfdir}
56     fi
57     if grep "CONFIG_UDHCPC=y" ${WORKDIR}/defconfig; then
58         install -d ${D}${sysconfdir}/udhcpc.d
59         install -m 0755 ${WORKDIR}/simple.script ${D}${sysconfdir}/udhcpc.d/50default
60     fi
61 }