aaa3a34c3660f57384301379a871d8a13e5d7de9
[vuplus_openembedded] / packages / nonworking / zethereal / zethereal_1.0.0.bb
1 DESCRIPTION = "The network packet dissector Ethereal, Qt/Embedded based Palmtop Environments Edition"
2 SECTION = "opie/applications"
3 PRIORITY = "optional"
4 LICENSE = "GPL"
5 DEPENDS = "glib-1.2 openssl"
6 HOMEPAGE = "http://www.cartel-info.fr/pbiondi/zaurus/"
7 APPNAME = "zethereal"
8 APPTYPE = "binary"
9 APPDESKTOP = "${WORKDIR}"
10 PR = "r0"
11
12 inherit autotools qmake-base
13
14 EXTRA_OECONF = "--disable-ethereal \
15                 --enable-tethereal \
16                 --disable-editcap \
17                 --disable-mergecap \
18                 --disable-text2pcap \
19                 --disable-idl2eth \
20                 --without-ucdsnmp \
21                 --disable-usr-local \
22                 --with-pcap=${STAGING_LIBDIR}/.. \
23                 --with-zlib=${STAGING_LIBDIR}/.. \
24                 --without-x"
25
26 export GLIB_CONFIG = "${STAGING_BINDIR}/glib-config"
27
28 CFLAGS += "-I${STAGING_INCDIR}/glib-1.2"
29 LIBS += "-lglib-1.2"
30
31 SRC_URI = "http://www.cartel-info.fr/pbiondi/zaurus/ethereal-0.9.5.tar.gz \
32            http://www.cartel-info.fr/pbiondi/zaurus/zethereal-1.0.tar.gz"
33 S = "${WORKDIR}/ethereal-0.9.5"
34
35 do_compile() {
36         oe_runmake SUBDIRS="wiretap"
37         mv ${WORKDIR}/qtopia .
38         ${AR} r libzethereal.a packet-*.o afn.o asn1.o column.o conditions.o     \
39                 capture_stop_conditions.o follow.o in_cksum.o ipproto.o pcap-u   \
40                 til.o prefs.o print.o ps.o ptvcursor.o reassemble.o ringbuffer.o \
41                 util.o xdlc.o xmlstub.o register.o
42         cd qtopia
43         qmake -spec ${QMAKESPEC} zethereal.pro && oe_runmake
44 }
45
46 do_stage() {
47         :
48 }
49
50 do_install() {
51         :
52 }
53