9d263de639e8d9b88d01563c60dffa32f4be4c95
[vuplus_openembedded] / packages / meta / slugos-packages.bb
1 # Meta package containing all the packages which build for SlugOS
2 #
3 # All packages in here must build with the slugos-???.conf distros,
4 # they do not necessarily work.
5 DESCRIPTION = "Packages that are compatible with the SlugOS firmware"
6 HOMEPAGE = "http://www.nslu2-linux.org"
7 LICENSE = "MIT"
8 PR = "r59"
9 CONFLICTS = "db3"
10
11 COMPATIBLE_MACHINE = "nslu2|ixp4xx"
12 EXCLUDE_FROM_WORLD = "1"
13 INHIBIT_DEFAULT_DEPS = "1"
14 ALLOW_EMPTY = "1"
15
16 # The list of packages to build for the slugos DISTRO.
17 # KEEP IN ALPHABETICAL ORDER
18 # Do *not* simply comment out a line. That will break. Instead
19 # remove the package and place it in the corresponding "broken" list
20
21 SLUGOS_PACKAGES = "\
22         alsa-lib \
23         alsa-utils \
24         apex-env \
25         apr \
26         asterisk \
27         asterisk-core-sounds-en-alaw \
28         asterisk-core-sounds-en-g729 \
29         asterisk-core-sounds-en-gsm \
30         asterisk-core-sounds-en-ulaw \
31         asterisk-extra-sounds-en-alaw \
32         asterisk-extra-sounds-en-g729 \
33         asterisk-extra-sounds-en-gsm \
34         asterisk-extra-sounds-en-ulaw \
35         asterisk-moh-freeplay-alaw \
36         asterisk-moh-freeplay-g729 \
37         asterisk-moh-freeplay-gsm \
38         asterisk-moh-freeplay-ulaw \
39         atftp \
40         audiofile \
41         aumix \
42         autoconf \
43         autofs \
44         automake \
45         bash \
46         beep \
47         bind \
48         binutils \
49         bison \
50         bluez-utils \
51         bluez-hcidump \
52         bogofilter \
53         bonnie++ \
54         boost \
55         bridge-utils \
56         bwmon \
57         bzip2 \
58         ccxstream \
59         cdparanoia \
60         cdstatus \
61         cherokee \
62         coreutils \
63         cron \
64         cryptsetup \
65         ctrlproxy \
66         cups \
67         curl \
68         cvs \
69         db \
70         devio \
71         devlabel \
72         diffstat \
73         diffutils \
74         dircproxy \
75         dnsmasq \
76         dropbear \
77         e2fsprogs \
78         e2fsprogs-libs \
79         expat \
80         ez-ipupdate \
81         fconfig \
82         fetchmail \
83         file \
84         findutils \
85         fis \
86         flac \
87         flex \
88         flite \
89         ftpd-topfield \
90         fuse \
91         gawk \
92         gcc \
93         gdb \
94         gdbm \
95         glib-2.0 \
96         gnu-config \
97         gphoto2 \
98         gpsd \
99         grep \
100         groff \
101         gtk-doc \
102         gzip \
103         hdparm \
104         hostap-daemon \
105         ifupdown \
106         inetutils \
107         iozone3 \
108         iperf \
109         ipkg-utils \
110         iptables \
111         ircp \
112         irssi \
113         joe \
114         jpeg \
115         kexec-tools \
116         lcdproc \
117         less \
118         libao \
119         libdvb \
120         libexif \
121         libid3tag \
122         liblockfile \
123         libmad \
124         libmikmod \
125         libogg \
126         libol \
127         libpam \
128         libpcre \
129         libpng \
130         libtool \
131         libupnp \
132         libusb \
133         libvorbis \
134         libxml2 \
135         lighttpd \
136         litestream \
137         logrotate \
138         lrzsz \
139         lsof \
140         lvm2 \
141         m4 \
142         madplay \
143         madwifi-ng \
144         mailx \
145         make \
146         man man-pages \
147         masqmail \
148         mdadm \
149         mediatomb \
150         memtester \
151         mgetty \
152         miau \
153         microcom \
154         minicom \
155         monit \
156         mpd \
157         mt-daapd \
158         mtd-utils \
159         mutt \
160         mysql \
161         nail \
162         nano \
163         ncftp \
164         ncurses \
165         net-tools \
166         netcat \
167         netpbm \
168         nfs-utils \
169         ngrep \
170         nmap \
171         ntfs-3g \
172         ntp \
173         ntpclient \
174         obexftp \
175         obexpush \
176         openobex-apps \
177         openntpd \
178         openobex \
179         openssh \
180         openvpn \
181         patch \
182         pciutils \
183         perl \
184         picocom \
185         pkgconfig \
186         popt \
187         portmap \
188         ppp \
189         procps \
190         psmisc \
191         puppy \
192         python \
193         quilt \
194         reiserfsprogs reiser4progs \
195         rng-tools \
196         rsync \
197         rtorrent \
198         samba \
199         sane-backends \
200         screen \
201         sed \
202         setpwc \
203         setserial \
204         sipsak \
205         slugimage \
206         smartmontools \
207         spandsp \
208         sqlite \
209         squid \
210         ssmtp \
211         strace \
212         streamripper \
213         stunnel \
214         sudo \
215         sysfsutils \
216         syslog-ng \
217         tar \
218         task-mokogateway-everything \
219         tcpdump \
220         thttpd \
221         tiff \
222         tzdata \
223         unrar \
224         unzip \
225         upslug2 \
226         usbutils \
227         ushare \
228         util-linux \
229         vim \
230         vlan \
231         vsftpd \
232         w3cam \
233         wakelan \
234         watchdog \
235         webcam-server \
236         wget \
237         wireless-tools \
238         wireshark \
239         wpa-supplicant \
240         wview-sim \
241         wview-vpro \
242         wview-wxt510 \
243         xinetd \
244         yp-tools ypbind ypserv \
245         zd1211-firmware \
246         zip \
247         zlib \
248         "
249
250 # Packages currently broken on all platforms
251 SLUGOS_BROKEN_PACKAGES = "\
252         ctorrent \
253         cyrus-imapd \
254         cyrus-sasl \
255         dsniff \
256         eciadsl \
257         gspcav1 \
258         linphone \
259         lirc-modules lirc \
260         madfu \
261         motion \
262         netatalk \
263         openldap \
264         postfix \
265         pvrusb2-mci \
266         pwc \
267         qc-usb-messenger \
268         task-native-sdk \
269         unionfs-modules unionfs-utils \
270         wview-sim-mysql wview-wxt510-mysql wview-vpro-mysql \
271         yeaphone \
272         zd1211 \
273         "
274
275 SLUGOS_EXTRA_PACKAGES ?= ""
276
277 # The package-index at the end causes regeneration of the Packages.gz and
278 # other control files.
279 DEPENDS = "\
280         slugos-image \
281         slugos-native \
282         task-proper-tools \
283         ${SLUGOS_PACKAGES} \
284         ${SLUGOS_EXTRA_PACKAGES} \
285         package-index \
286         "
287
288 inherit meta
289
290 do_package_write_ipk() {
291 }