2c97cf6d355bcbaf10e1765952dc6b42829d4f46
[vuplus_openembedded] / packages / kexecboot / linux-kexecboot_2.6.24.bb
1 require linux-kexecboot.inc
2
3 PR = "r7"
4
5 DEFAULT_PREFERENCE = "-1"
6 DEFAULT_PREFERENCE_collie = "-1"
7 DEFAULT_PREFERENCE_poodle = "1"
8 DEFAULT_PREFERENCE_qemux86 = "-1"
9 DEFAULT_PREFERENCE_tosa = "1"
10 DEFAULT_PREFERENCE_c7x0 = "1"
11 DEFAULT_PREFERENCE_akita = "1"
12 DEFAULT_PREFERENCE_spitz = "1"
13
14 # Handy URLs
15 # git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git;protocol=git;tag=ef7d1b244fa6c94fb76d5f787b8629df64ea4046
16 # ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2
17 # ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/linux-2.6.20-rc4.tar.bz2
18 # ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/patch-2.6.18-rc6.bz2;patch=1
19 # ${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/snapshots/patch-2.6.18-rc2-git1.bz2;patch=1
20 # ${KERNELORG_MIRROR}/pub/linux/kernel/people/alan/linux-2.6/2.6.10/patch-2.6.10-ac8.gz;patch=1
21 # ${KERNELORG_MIRROR}/pub/linux/kernel/people/akpm/patches/2.6/2.6.14-rc2/2.6.14-rc2-mm1/2.6.14-rc2-mm1.bz2;patch=1
22
23 # Patches submitted upstream are towards top of this list 
24 # Hacks should clearly named and at the bottom
25 SRC_URI += "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
26            ${RPSRC}/export_atags-r2.patch;patch=1;status=pending \
27            ${RPSRC}/lzo_crypto-r2.patch;patch=1;status=pending \
28            ${RPSRC}/corgi_rearrange_lcd-r0.patch;patch=1;status=pending \
29            file://hrw-hostapcard.patch;patch=1;status=pending \
30            ${RPSRC}/allow_disable_deferrred-r0.patch;patch=1 \
31            ${RPSRC}/lzo_jffs2_sysfs-r1.patch;patch=1 \
32            ${RPSRC}/hx2750_base-r33.patch;patch=1 \
33            ${RPSRC}/hx2750_bl-r9.patch;patch=1 \
34            ${RPSRC}/hx2750_pcmcia-r3.patch;patch=1 \
35            ${RPSRC}/pxa_keys-r8.patch;patch=1 \
36            ${RPSRC}/tsc2101-r18.patch;patch=1 \
37            ${RPSRC}/hx2750_test1-r8.patch;patch=1 \
38            ${RPSRC}/input_power-r10.patch;patch=1 \
39            ${RPSRC}/pxa25x_cpufreq-r2.patch;patch=1 \
40            ${RPSRC}/sharpsl_pm_fixes1-r0.patch;patch=1 \
41            ${RPSRC}/pm_changes-r1.patch;patch=1 \
42            ${RPSRC}/usb_add_epalloc-r4.patch;patch=1 \
43            ${RPSRC}/usb_pxa27x_udc-r8.patch;patch=1 \
44            ${RPSRC}/locomo_kbd_tweak-r1a.patch;patch=1 \
45            ${RPSRC}/pxa27x_overlay-r8.patch;patch=1 \
46            ${RPSRC}/w100_extaccel-r2.patch;patch=1 \
47            ${RPSRC}/w100_extmem-r1.patch;patch=1 \
48            ${RPSRC}/poodle_pm-r5.patch;patch=1 \
49            ${RPSRC}/poodle_lcd_hack-r0.patch;patch=1 \
50            ${RPSRC}/poodle_asoc_fix-r1.patch;patch=1 \
51            file://pxa27x-resume.patch;patch=1;status=external \
52            file://mtd-module.patch;patch=1;status=external \
53            file://wm8750-treble.patch;patch=1;status=external \
54            file://spitz_h_rewrite.patch;patch=1;status=external \
55            file://pxa2xx_udc-clock.patch;patch=1 \
56            file://sharpsl-rc-r1.patch;patch=1 \
57            file://sharpsl-rc-r2.patch;patch=1 \
58            file://squashfs3.3.patch;patch=1;status=external \
59 #           ${RPSRC}/logo_oh-r1.patch.bz2;patch=1;status=unmergable \
60            ${RPSRC}/pxa-linking-bug.patch;patch=1;status=unmergable \
61            file://hostap-monitor-mode.patch;patch=1;status=unmergable \
62            file://serial-add-support-for-non-standard-xtals-to-16c950-driver.patch;patch=1;status=unmergable \
63            ${RPSRC}/mmcsd_large_cards-r1.patch;patch=1;status=hack \
64            ${RPSRC}/mmcsd_no_scr_check-r2.patch;patch=1;status=hack \
65            ${RPSRC}/integrator_rgb-r1.patch;patch=1;status=hack \
66            ${RPSRC}/pxa_cf_initorder_hack-r1.patch;patch=1;status=hack \
67            file://pxa-serial-hack.patch;patch=1;status=hack \
68            file://connectplus-remove-ide-HACK.patch;patch=1;status=hack \
69            file://connectplus-prevent-oops-HACK.patch;patch=1;status=hack \
70            file://binutils-buildid-arm.patch;patch=1 \
71            file://versatile-armv6.patch;patch=1 \
72            file://htcuni.patch;patch=1 \
73            "
74
75 # FIXMEs before made default       
76 # ${RPSRC}/mmcsd_no_scr_check-r1.patch;patch=1;status=hack
77
78
79 # Add this to enable pm debug code (useful with a serial lead)
80 #  ${RPSRC}/sharpsl_pm_debug-r0.patch;patch=1
81
82 # Disabled until I find the reason this gives issues with cdc_subset
83 #            ${RPSRC}/usb_rndis_tweaks-r0.patch;patch=1 \
84
85
86 SRC_URI_append_collie = "\
87         ${TKSRC}/mtd-sharp-flash-hack-r4.patch;patch=1 \
88         ${TKSRC}/mcp-sa11x0-r0.patch;patch=1 \
89         ${TKSRC}/locomo-r1.patch;patch=1 \
90         ${TKSRC}/collie-kexec-r1.patch;patch=1 \
91         ${TKSRC}/sharpsl_pm-4.patch;patch=1 \
92         ${TKSRC}/collie_pm-3.patch;patch=1 \
93         ${TKSRC}/ucb1x00_suspend.patch;patch=1 \
94         ${TKSRC}/collie-ts.patch;patch=1 \
95         ${TKSRC}/pcmcia_suspend.patch;patch=1 \
96         ${TKSRC}/locomo_spi-6.patch;patch=1 \
97         ${TKSRC}/config.patch;patch=1 \
98         ${TKSRC}/mmc-spi.patch;patch=1 \
99         ${TKSRC}/linux-2.6.24-SIMpad-rtc-sa1100.patch;patch=1 \
100         ${TKSRC}/sa1100_spinlock.patch;patch=1 \
101         ${TKSRC}/sa1100-dma.patch;patch=1 \
102 "
103
104 SRC_URI_append_poodle = "\
105            ${RPSRC}/poodle_serial_vcc-r0.patch;patch=1 \
106            file://poodle_ts.patch;patch=1 \
107            file://pxafb.patch;patch=1 \
108 "
109
110 SRC_URI_append_tosa = "\
111            file://tosa/0001-Allow-runtime-registration-of-regions-of-memory-that.patch;patch=1 \
112            file://tosa/0002-Modify-dma_alloc_coherent-on-ARM-so-that-it-supports.patch;patch=1 \
113            file://tosa/0003-Core-MFD-support.patch;patch=1 \
114            file://tosa/0004-Add-support-for-tc6393xb-MFD-core.patch;patch=1 \
115            file://tosa/0005-Add-support-for-tc6387xb-MFD-core.patch;patch=1 \
116            file://tosa/0006-Add-support-for-t7l66xb-MFD-core.patch;patch=1 \
117            file://tosa/0007-Common-headers-for-TMIO-MFD-subdevices.patch;patch=1 \
118            file://tosa/0008-Nand-driver-for-TMIO-devices.patch;patch=1 \
119            file://tosa/0009-FB-driver-for-TMIO-devices.patch;patch=1 \
120            file://tosa/0010-OHCI-driver-for-TMIO-devices.patch;patch=1 \
121            file://tosa/0011-MMC-driver-for-TMIO-devices.patch;patch=1 \
122            file://tosa/0012-Tosa-keyboard-support.patch;patch=1 \
123            file://tosa/0013-USB-gadget-pxa2xx_udc-supports-inverted-vbus.patch;patch=1 \
124            file://tosa/0014-tosa_udc_use_gpio_vbus.patch.patch;patch=1 \
125            file://tosa/0015-sharpsl-export-params.patch;patch=1 \
126            file://tosa/0016-This-patch-fixes-the-pxa25x-clocks-definitions-to-ad.patch;patch=1 \
127            file://tosa/0026-I-don-t-think-we-should-check-for-IRQs-when-determin.patch;patch=1 \
128            file://tosa/0027-Add-LiMn-one-of-the-most-common-for-small-non-recha.patch;patch=1 \
129            file://tosa/0028-Add-suspend-resume-wakeup-support-for-pda_power.patch;patch=1 \
130            file://tosa/0029-Support-using-VOLTAGE_-properties-for-apm-calculati.patch;patch=1 \
131            file://tosa/0030-Core-driver-for-WM97xx-touchscreens.patch;patch=1 \
132            file://tosa/0031-Add-chip-driver-for-WM9705-touchscreen.patch;patch=1 \
133            file://tosa/0032-Add-chip-driver-for-WM9712-touchscreen.patch;patch=1 \
134            file://tosa/0033-Add-chip-driver-for-WM9713-touchscreen.patch;patch=1 \
135            file://tosa/0034-Driver-for-WM97xx-touchscreens-in-streaming-mode-on.patch;patch=1 \
136            file://tosa/0035-Build-system-and-MAINTAINERS-entry-for-WM97xx-touchs.patch;patch=1 \
137            file://tosa/0036-Set-id-to-1-for-wm97xx-subdevices.patch;patch=1 \
138            file://tosa/0037-Don-t-lock-the-codec-list-in-snd_soc_dapm_new_widget.patch;patch=1 \
139            file://tosa/0038-Don-t-lock-the-codec-list-in-snd_soc_dapm_new_widget.patch;patch=1 \
140            file://tosa/0044-fix-tmio_mmc-debug-compilation.patch;patch=1 \
141            file://tosa/0045-Update-tmio_ohci.patch;patch=1 \
142            file://tosa/0046-patch-tc6393xb-cleanup.patch;patch=1 \
143            file://tosa/0047-tc6393xb-use-bitmasks-instead-of-bit-field-structs.patch;patch=1 \
144            file://tosa/0048-tc6393xb-GPIO-support.patch;patch=1 \
145            file://tosa/0049-platform-support-for-TMIO-on-tosa.patch;patch=1 \
146            file://tosa/0050-tosa-update-for-tc6393xb-gpio.patch;patch=1 \
147            file://tosa/0051-fix-sound-soc-pxa-tosa.c-to-new-gpio-api.patch;patch=1 \
148            file://tosa/0052-tosa-platform-backlight-support.patch;patch=1 \
149            file://tosa/0053-sound-soc-codecs-wm9712.c-28.patch;patch=1 \
150            file://tosa/0054-sound-soc-codecs-wm9712.c-2.patch;patch=1 \
151            file://tosa/0055-Add-GPIO_POWERON-to-the-list-of-devices-that-we-supp.patch;patch=1 \
152            file://tosa/0058-Fix-tosakbd-suspend.patch;patch=1 \
153            file://tosa/0059-patch-tosa-wakeup-test.patch;patch=1 \
154            file://tosa/0060-Add-support-for-power_supply-on-tosa.patch;patch=1 \
155            file://tosa/0061-tosa-bat-unify.patch;patch=1 \
156            file://tosa/0062-tosa-bat-fix-charging.patch;patch=1 \
157            file://tosa/0063-patch-tosa-bat-jacket-detect.patch;patch=1 \
158            file://tosa/0064-Export-modes-via-sysfs.patch;patch=1 \
159            file://tosa/0065-wm97xx-core-fixes.patch;patch=1 \
160            file://tosa/0066-tmiofb_probe-should-be-__devinit.patch;patch=1 \
161            file://tosa/0067-modeswitching.patch;patch=1 \
162            file://tosa/0068-Preliminary-tosa-denoiser.patch;patch=1 \
163            file://tosa/0019-pxa-remove-periodic-mode-emulation-support.patch;patch=1 \
164            file://tosa/0020-Provide-dew-device-clock-backports-from-2.6.24-git.patch;patch=1 \
165            file://tosa/0021-Add-an-empty-drivers-gpio-directory-for-gpiolib-infr.patch;patch=1 \
166            file://tosa/0022-Provide-new-implementation-infrastructure-that-platf.patch;patch=1 \
167            file://tosa/0023-This-adds-gpiolib-support-for-the-PXA-architecture.patch;patch=1 \
168            file://tosa/0024-Update-Documentation-gpio.txt-primarily-to-include.patch;patch=1 \
169            file://tosa/0025-Signed-off-by-Dmitry-Baryshkov-dbaryshkov-gmail.co.patch;patch=1 \
170            file://tosa/0039-Add-generic-framework-for-managing-clocks.patch;patch=1 \
171            file://tosa/0040-Clocklib-debugfs-support.patch;patch=1 \
172            file://tosa/0041-From-80a359e60c2aec59ccf4fca0a7fd20495f82b1d2-Mon-Se.patch;patch=1 \
173            file://tosa/0042-Use-correct-clock-for-IrDA-on-pxa.patch;patch=1 \
174            file://tosa/0043-Use-clocklib-for-sa1100-sub-arch.patch;patch=1 \
175            file://tosa/0056-Support-resetting-by-asserting-GPIO-pin.patch;patch=1 \
176            file://tosa/0057-Clean-up-tosa-resetting.patch;patch=1 \
177            file://tosa/0001-pxa2xx-ac97-switch-AC-unit-to-correct-state-before.patch;patch=1 \
178            file://tosa/tosa-bl-fixup.diff;patch=1 \
179            file://tosa/tmiofb-fix-unaccel.patch;patch=1 \
180            "
181 #           file://tosa/0017-Convert-pxa2xx-UDC-to-use-debugfs.patch;patch=1 \
182 #           file://tosa/0018-Fix-the-pxa2xx_udc-to-balance-calls-to-clk_enable-cl.patch;patch=1 \
183
184 SRC_URI_append_htcuniversal ="\
185         file://htcuni-acx.patch;patch=1;status=external \
186         "
187
188 SRC_URI_append_zylonite ="\
189         file://pxa_fb_overlay.patch;patch=1 \
190         file://zylonite-boot.patch;patch=1 \
191         "
192
193 S = "${WORKDIR}/linux-2.6.24"