b234664fe6f025e5909d104a015ed899285b3f57
[vuplus_openembedded] / packages / e17 / entrance_20060128.bb
1 DESCRIPTION = "Entrance is the Enlightenment login manager"
2 SECTION = "e/apps"
3 LICENSE = "MIT"
4 # can also use pam and crypt
5 DEPENDS = "edb edb-native evas-x11 ecore-x11 edje esmart-x11 bash keylaunch detect-stylus xserver-common"
6 RDEPENDS += "bash keylaunch detect-stylus xserver-common glibc-gconv-iso8859-1"
7 HOMEPAGE = "http://www.enlightenment.org"
8 MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
9 PR = "r11"
10
11 SRC_URI = "cvs://anonymous@thinktux.net/root;module=e17/apps/entrance;date=${PV} \
12            file://config-db.patch;patch=1 \
13            file://allow-missing-xsession.patch;patch=1 \
14            file://run-Xinit.patch;patch=1 \
15            file://set-display-env.patch;patch=1 \
16            file://fix-auth-mode.patch;patch=1 \
17            file://use-bash.patch;patch=1 \
18            file://Sessions"
19
20 S = "${WORKDIR}/entrance"
21
22 inherit autotools update-rc.d
23
24 INITSCRIPT_NAME = "entrance"
25 INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
26
27 EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR}/edje_cc \
28                 --with-xsession=/etc/X11/Xsession \
29                 --with-auth-mode=0"
30
31 FILES += "${datadir}"
32
33 do_install_append() {
34         install -d ${D}/etc/X11/Xsession.d
35         install -d ${D}/etc/X11/Sessions
36         
37         install -m 755 ${WORKDIR}/Sessions/* ${D}/etc/X11/Sessions
38 }