a831a1515b807797b8bdc5c28dd2cdb3a325daba
[vuplus_openembedded] / packages / e17 / entrance_0.9.0.010.bb
1 DESCRIPTION = "Entrance is the Enlightenment login manager"
2 LICENSE = "MIT BSD"
3 # can also use pam and crypt
4 DEPENDS = "evas ecore edje esmart bash keylaunch xserver-common login-manager"
5 RDEPENDS += "glibc-gconv-iso8859-1 entrance-themes"
6 PR = "r0"
7
8 inherit e
9
10 SRC_URI += "\
11            file://config-db.patch;patch=1 \
12            file://allow-missing-xsession.patch;patch=1 \
13            file://run-Xinit.patch;patch=1 \
14            file://fix-auth-mode.patch;patch=1 \
15            file://use-bash.patch;patch=1 \
16            file://Sessions"
17
18 S = "${WORKDIR}/entrance-${PV}"
19
20 EXTRA_OECONF = "--with-edje-cc=${STAGING_BINDIR_NATIVE}/edje_cc \
21                 --with-xsession=/etc/X11/Xsession \
22                 --with-auth-mode=0"
23
24 FILES_${PN}-dbg += "${libexecdir}/entrance/.debug/*"
25
26 do_install_append() {
27         install -d ${D}/etc/X11/Xsession.d
28         install -d ${D}/etc/X11/Sessions
29
30         install -m 755 ${WORKDIR}/Sessions/* ${D}/etc/X11/Sessions
31
32         install -d ${D}/etc/X11/login-managers/
33         mv ${D}/etc/init.d/entrance ${D}/etc/X11/login-managers/entrance
34 }