12cbea4a126c10ea31fd40e1fff0267e2faa757b
[vuplus_openembedded] / packages / dsplink / dmai_1.20.bb
1 DESCRIPTION = "Davinci (and OMAP) Multimedia Application Interface"
2 DEPENDS = "virtual/kernel codec-engine"
3 LICENCE = "unknown"
4
5 require ti-paths.inc
6
7 # https://www-a.ti.com/downloads/sds_support/applications_packages/dmai/dmai_1_20_00_06/dmai_setuplinux_1_20_00_06.bin
8 # Install the above link and put the dmai_1_20_00_06.tar.gz file in the same directory as this recipe
9 SRC_URI = "file://dmai_1_20_00_06.tar.gz \
10            file://update-cpu-name.patch;patch=1 \
11            file://update-fb-display.patch;patch=1 \
12            file://update-v4l2-display.patch;patch=1 \
13            file://do-not-panic-on-mixer-failure.patch;patch=1 \
14            file://support-32bit-align.patch;patch=1 \
15 #          file://resizer-fix.patch;patch=1 \
16            file://built-with-angstrom.patch;patch=1 \
17           "
18
19 S = "${WORKDIR}/dmai_1_20_00_06"
20 # Yes, the xdc stuff still breaks with a '.' in PWD
21 PV = "120"
22
23 PACKAGE_ARCH = "${MACHINE_ARCH}"
24
25 TARGET = "all"
26 TARGET_neuros-osd2 = " dm6446_al dm6446_db"
27 TARGET_beagleboard = " o3530_al"
28
29 do_compile() {
30         cd packages/ti/sdo/dmai
31         oe_runmake clean
32         oe_runmake ${TARGET} C_FLAGS="-O2 -I${STAGING_INCDIR}"
33         cd apps
34         oe_runmake clean
35         oe_runmake ${TARGET}
36 }
37
38 do_install () {
39         oe_runmake install
40 }
41
42 do_stage () {
43         :
44 }