2a8e0ee951ed9611ad02005946345933132c40fd
[vuplus_openembedded] / packages / bash / bash_3.0.bb
1 DESCRIPTION = "An sh-compatible command language interpreter."
2 HOMEPAGE = "http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
3 DEPENDS = "ncurses"
4 SECTION = "base/shell"
5 LICENSE = "GPL"
6 PR = "r7"
7
8 SRC_URI = "${GNU_MIRROR}/bash/bash-${PV}.tar.gz \
9         file://bash-3.0-fixes.patch;patch=1 \
10         file://signames-mipsel.diff;patch=1"
11
12 inherit autotools gettext
13
14 PARALLEL_MAKE = ""
15
16 bindir = "/bin"
17 sbindir = "/sbin"
18
19 EXTRA_OECONF = "--with-ncurses"
20 export CC_FOR_BUILD = "${BUILD_CC}"
21
22 do_configure () {
23         gnu-configize
24         oe_runconf
25 }
26
27 pkg_postinst () {
28         touch ${sysconfdir}/shells
29         grep -q "bin/bash" ${sysconfdir}/shells || echo /bin/bash >> ${sysconfdir}/shells
30         grep -q "bin/sh" ${sysconfdir}/shells || echo /bin/sh >> ${sysconfdir}/shells
31 }